summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 00:35:27 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:38 +0000
commitb37e88acde2bc04a4d132d0ead74ff7c511260b1 (patch)
tree581d8399f392a6ef0610f0b3e1633baa6d94d1d5 /games-arcade/epiar
parentgames-arcade/epiar: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.gz
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.tar.bz2
gentoo-b37e88acde2bc04a4d132d0ead74ff7c511260b1.zip
games-arcade/epiar: add 0.5.1
Includes patches to: * Unbundle Lua 5.1 * Fix Bashisms Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/epiar')
-rw-r--r--games-arcade/epiar/Manifest1
-rw-r--r--games-arcade/epiar/epiar-0.5.1.ebuild49
-rw-r--r--games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch41
-rw-r--r--games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch49
4 files changed, 140 insertions, 0 deletions
diff --git a/games-arcade/epiar/Manifest b/games-arcade/epiar/Manifest
index baa5cbae42a2..2c4d09e0caa1 100644
--- a/games-arcade/epiar/Manifest
+++ b/games-arcade/epiar/Manifest
@@ -1 +1,2 @@
DIST epiar-0.5.0-src.zip 8809392 BLAKE2B c29c541f5841da91d13f7ccddfa2d2175265a434ae03e2ed87a64cd5c177d7139ff2cf44ec679ec023fe783427868f0f234c6f5f49d0d52ab08be852d424ba59 SHA512 22d8655aefd3aa071de064aeeed40d8780fb32ee702e657c8b8a723c381b6825ae9b5820cf5b29991e14bc264c443d0b24f88656b4997a6270383aa080c15f3e
+DIST epiar-0.5.1.tar.gz 35576547 BLAKE2B 6648eeccbe86e6935f53d83e5a58aa5839dbec2f5a8c408fd4d8a95e303daa8877c001f5dd4e37a2b72b3c24df646236c850c57c1a1d000fca63177cf075c729 SHA512 ce09aaafc455f3f9721d46a1703bf110ae00041234627b2b5fb4a9489f38672d0d0600b01a65d210728a50b596a51aacddc525d50d1138a6959db421b9384c40
diff --git a/games-arcade/epiar/epiar-0.5.1.ebuild b/games-arcade/epiar/epiar-0.5.1.ebuild
new file mode 100644
index 000000000000..0d640921c5d5
--- /dev/null
+++ b/games-arcade/epiar/epiar-0.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+inherit autotools lua-single
+
+DESCRIPTION="A space adventure/combat game"
+HOMEPAGE="https://epiar.net/"
+SRC_URI="https://github.com/cthielen/Epiar/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-games/physfs
+ dev-libs/libxml2
+ media-libs/ftgl
+ media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ ${LUA_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libX11
+ virtual/opengl
+"
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.1-unbundle-lua5.1.patch
+ "${FILESDIR}"/${PN}-0.5.1-fix-bashisms.patch
+)
+
+src_prepare() {
+ default
+
+ # Remove bundled Lua 5.1
+ rm -rf source/lua || die
+
+ eautoreconf
+}
diff --git a/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch b/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch
new file mode 100644
index 000000000000..cc064799366a
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5.1-fix-bashisms.patch
@@ -0,0 +1,41 @@
+From 99b92a9d29f61beae05227c4f10ed54c41c02b11 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 7 Apr 2021 00:29:01 +0000
+Subject: [PATCH 2/2] Fix bashisms
+
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b5a70d5..4d3d598 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,13 +22,13 @@ AC_PROG_RANLIB
+ AC_LANG(C++)
+
+ dnl Check for a C++ compiler
+-if test "$ac_cv_prog_cxx_g" == no
++if test "$ac_cv_prog_cxx_g" = no
+ then
+ AC_MSG_ERROR([Cannot find a working C++ compiler])
+ fi
+
+ dnl Set PKG_CONFIG if necessary
+-if test "$PKG_CONFIG" == ""
++if test "$PKG_CONFIG" = ""
+ then
+ PKG_CONFIG=`which pkg-config`
+ fi
+@@ -71,7 +71,7 @@ AC_CHECK_LIB(physfs, PHYSFS_init, have_physfs_lib=yes)
+ if test x$have_physfs_hdr = xyes -a x$have_physfs_lib = xyes; then
+ enable_physfs="yes"
+ else
+-dnl if test "$ac_cv_prog_cxx_g" == no
++dnl if test "$ac_cv_prog_cxx_g" = no
+ dnl then
+ AC_MSG_ERROR([Could not find PhysicsFS])
+ dnl fi
+--
+2.31.1
+
diff --git a/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch b/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch
new file mode 100644
index 000000000000..e80615e549b6
--- /dev/null
+++ b/games-arcade/epiar/files/epiar-0.5.1-unbundle-lua5.1.patch
@@ -0,0 +1,49 @@
+From 0ed05474a5ea50cc972fae620fd1580ed0026fca Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 7 Apr 2021 00:28:07 +0000
+Subject: [PATCH 1/2] Unbundle Lua 5.1 and dynamically link with system copy
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ Makefile.am | 6 ++----
+ configure.ac | 3 +++
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 334b80e..b24ad29 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-AM_CXXFLAGS = -I$(top_srcdir)/source/ -I$(top_srcdir)/source/lua/src
++AM_CXXFLAGS = -I$(top_srcdir)/source/ $(LUA_CFLAGS)
+
+ bin_PROGRAMS = epiar
+
+@@ -74,9 +74,7 @@ epiar_SOURCES = source/main.cpp \
+ source/Utilities/trig.cpp \
+ source/Utilities/xml.cpp
+
+-epiar_LDADD = source/lua/src/liblua.a
+-
+-SUBDIRS=source/lua
++epiar_LDADD = $(LUA_LIBS)
+
+ include resources/Animations/Makefile.am
+ include resources/audio/Makefile.am
+diff --git a/configure.ac b/configure.ac
+index 17202ae..b5a70d5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -99,6 +99,9 @@ case "$target" in *-apple-darwin*)
+ LIBS="$LIBS `xml2-config --libs`"
+ esac
+
++dnl Check for Lua 5.1
++PKG_CHECK_MODULES([LUA], [lua5.1], [], [AC_MSG_ERROR([Could not find needed Lua 5.1])])
++
+ dnl Check for SDL
+ SDL_VERSION=1.2.10
+
+--
+2.31.1
+