summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/moleinvasion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/moleinvasion')
-rw-r--r--games-arcade/moleinvasion/Manifest2
-rw-r--r--games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch18
-rw-r--r--games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch11
-rw-r--r--games-arcade/moleinvasion/metadata.xml8
-rw-r--r--games-arcade/moleinvasion/moleinvasion-0.4-r1.ebuild45
5 files changed, 84 insertions, 0 deletions
diff --git a/games-arcade/moleinvasion/Manifest b/games-arcade/moleinvasion/Manifest
new file mode 100644
index 000000000000..15071b67155a
--- /dev/null
+++ b/games-arcade/moleinvasion/Manifest
@@ -0,0 +1,2 @@
+DIST MoleInvasion-0.4.tar.bz2 11213919 SHA256 a011361f07c06d79a5ba6d110d7b06b59da2c57970515d24fab063fe991d922c SHA512 e1d661758391c24b9daab8ba183a265b77f4b2454c8a55f8405b63a78e040491d0c1421a64736a590a574c364e43a8989ef1b958fa565419938d0c8daadbe03f WHIRLPOOL 0de5f87ca6d42e0eb347f7199276d3af37ef6584eaf9c44281e161b3bc6e55e8d5c1caedf6fdbec45192ccc296ebc1b0e3d1e660a0d72c26a3eca8395e70af00
+DIST moleinvasion-music-20090731.tar.gz 83772534 SHA256 ef973ca073026dbe944c7c61058b1437e19f5abe144e9451aed6feffe3d72c73
diff --git a/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch b/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch
new file mode 100644
index 000000000000..357f1bc2b466
--- /dev/null
+++ b/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch
@@ -0,0 +1,18 @@
+--- src/MoleInvasion.c
++++ src/MoleInvasion.c
+@@ -159,6 +159,7 @@
+ else
+ printf("Video mode set to %ux%u at %u bpp\n",800, 600, bpp);
+
++ if(g_opengl) {
+ /* pour opengl */
+ glEnable (GL_TEXTURE_2D);
+ glTexParameteri (GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, GL_LINEAR);
+@@ -169,6 +170,7 @@
+ glEnable( GL_BLEND );
+ glMatrixMode(GL_PROJECTION);
+ /* fin opengl */
++ }
+
+ /* titre */
+ SDL_WM_SetCaption ("Mole Invasion", NULL);
diff --git a/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
new file mode 100644
index 000000000000..6f4c5fdf4075
--- /dev/null
+++ b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2011-06-14 22:12:00.920386798 +0200
++++ Makefile 2011-06-14 22:12:22.118716548 +0200
+@@ -11,7 +11,7 @@
+ EDTOB = editor
+ EDWOB = editworld
+
+-LINLIBS=$(LDLIBS) -lGL
++LINLIBS=$(LDLIBS) -lGL -ldl
+ LINEXE = ../lin/moleinvasion
+ LINEDT = ../lin/editor
+ LINEDW = ../lin/editworld
diff --git a/games-arcade/moleinvasion/metadata.xml b/games-arcade/moleinvasion/metadata.xml
new file mode 100644
index 000000000000..96ceb3270a0d
--- /dev/null
+++ b/games-arcade/moleinvasion/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="music">Download and install the music files</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-arcade/moleinvasion/moleinvasion-0.4-r1.ebuild b/games-arcade/moleinvasion/moleinvasion-0.4-r1.ebuild
new file mode 100644
index 000000000000..500d93420ab2
--- /dev/null
+++ b/games-arcade/moleinvasion/moleinvasion-0.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Mole infested 2D platform game"
+HOMEPAGE="http://moleinvasion.tuxfamily.org/"
+SRC_URI="ftp://download.tuxfamily.org/minvasion/packages/MoleInvasion-${PV}.tar.bz2
+ music? ( mirror://gentoo/${PN}-music-20090731.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="music"
+
+DEPEND="media-libs/libsdl[opengl,video]
+ virtual/opengl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ use music && mv -f "${WORKDIR}"/music ../
+ sed -i \
+ -e '/^CFLAGS/s:= -g:+=:' \
+ -e '/^LDFLAGS/d' \
+ -e "/^FINALEXEDIR/s:/usr.*:${GAMES_BINDIR}:" \
+ -e "/^FINALDATADIR/s:/usr.*:${GAMES_DATADIR}/${PN}:" \
+ Makefile \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-opengl.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-data
+ newicon ../gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Mole Invasion"
+ doman ../debian/*.6
+ prepgamesdirs
+}