summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-05 12:31:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-05 19:37:30 -0400
commite11dd370dd5b16fe85e53e78180dae61617748be (patch)
tree78ba728053ea33ce8e8df95e1396cc5e5c564d54 /games-arcade
parentgames-arcade/jumpnbump: enable py3.12 + tidy (diff)
downloadgentoo-e11dd370dd5b16fe85e53e78180dae61617748be.tar.gz
gentoo-e11dd370dd5b16fe85e53e78180dae61617748be.tar.bz2
gentoo-e11dd370dd5b16fe85e53e78180dae61617748be.zip
games-arcade/solarwolf: enable py3.12 + tidy
Closes: https://bugs.gentoo.org/929571 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5_p3.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.5_p3.ebuild b/games-arcade/solarwolf/solarwolf-1.5_p3.ebuild
index 63dbad85cf2b..b9697d085237 100644
--- a/games-arcade/solarwolf/solarwolf-1.5_p3.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.5_p3.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit desktop python-single-r1
-MY_P="${PN}-$(ver_cut 1-2)"
+MY_P=${PN}-$(ver_cut 1-2)
DESCRIPTION="Action/arcade recreation of SolarFox"
HOMEPAGE="https://www.pygame.org/shredwheat/solarwolf/index.shtml"
SRC_URI="
http://www.pygame.org/shredwheat/solarwolf/${MY_P}.tar.gz
- mirror://debian/pool/main/s/solarwolf/${MY_P/-/_}+dfsg1-${PV/*_p}.debian.tar.xz"
-S="${WORKDIR}/${MY_P}"
+ mirror://debian/pool/main/s/solarwolf/${MY_P/-/_}+dfsg1-${PV/*_p}.debian.tar.xz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="LGPL-2.1"
SLOT="0"
@@ -24,7 +25,8 @@ RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/pygame[${PYTHON_USEDEP}]')
media-libs/sdl2-image[gif,png]
- media-libs/sdl2-mixer[mod,vorbis]"
+ media-libs/sdl2-mixer[mod,vorbis]
+"
BDEPEND="${PYTHON_DEPS}"
PATCHES=(