summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-09-13 14:24:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-09-13 14:24:58 +0000
commit1a3b6786a8cb49f8abd383ebdfec66cd3dceb7fa (patch)
tree8148d4e36dc3156f4a332a9f1bf35da2b662b70a /games-board
parentdev-python/urllib3: Bump to 2.2.3 (diff)
downloadgentoo-1a3b6786a8cb49f8abd383ebdfec66cd3dceb7fa.tar.gz
gentoo-1a3b6786a8cb49f8abd383ebdfec66cd3dceb7fa.tar.bz2
gentoo-1a3b6786a8cb49f8abd383ebdfec66cd3dceb7fa.zip
games-board/stockfish: add 17
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/stockfish/Manifest3
-rw-r--r--games-board/stockfish/stockfish-17.ebuild88
2 files changed, 91 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index c8d81f703dbd..defd22d5c7a4 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -14,3 +14,6 @@ DIST stockfish-16.1-nn-b1a57edbea57.nnue 65429575 BLAKE2B 22020e7e3a59530c2a9d29
DIST stockfish-16.1-nn-baff1ede1f90.nnue 3480122 BLAKE2B cb573cd1537b07afb6162c4c42da6363f3aaab472fedea8e2059ac481a7b774100637a067aa405c44f2d7f792ca74c32ed1e58ea8c4e00adafe1e8f0e3092a92 SHA512 56358da4810a2bf5b903668d8243ec888a0a64302a893207074b3f1644c9877ddd4557303f025eabcc6e0f7b31af42c1265ba2fd34209df9dd0ea205d4f4a8e9
DIST stockfish-16.1.tar.gz 176846 BLAKE2B d1cbc980496a8aea6668d50c2f24b69e2de39858dd50ff4fd807a3fca470e8e319901dd638bc09bb00c4bb0f886e4a8e87b021a7ff6c44edc540bfab45ceebcf SHA512 39962d92deba234e625b1f89568c9c469ecae02209c9c68dfd380034c70ab950d917bc5b7fa202a80b0e5cb59b6f3ef726b128ec9a28969e966308ebc7fbb056
DIST stockfish-16.tar.gz 195462 BLAKE2B 0f2a55baae13a9abd682672dd88aebcfcd66e4bf6cf1d0886eba48ff331e9aa853bd44fab74c6dbb8a1db4873bf8fe9f98b33ab713878d071950095bd3c0ba82 SHA512 cc8728bd76cb71ab2e3dddb909acf3ebd26a7d44130509dcb2cd90959c939d7324abebf2c69092230028333428a90fa345a10fcb4e9c50e53f4958c61daedcc7
+DIST stockfish-17-nn-1111cefa1111.nnue 74874478 BLAKE2B b2179b5727b13984be82f88715a55df7a84959944c92bd5758b492f6f8bd8f241696b491339ce64a0aaa059e3591115ff04d2382f7371075df5aea729cfa2dec SHA512 0814a77442d14f9eee02b1d45195cc8c9ed58e91d10ac22be56f562835baedc77094b442d23f2e088779e58d798184eabc8dfc919558e1ede552cde35d448025
+DIST stockfish-17-nn-37f18f62d772.nnue 3519630 BLAKE2B fe51553da8c051e66ecbc5e167f4a8b6c5701f80a9174e487b6a40962753c8a9ac96af2ff47df707b5044f83ef4baeac74b3154fd908dbe9728b40f020b8a7e6 SHA512 bf4d01f8cbff94dbff484636dd0351cd66f37eeaea7b7dbe16a3bfe231ae78cfabdeed040b789b64049c6063ef0dca21e4a4f332b99e49a52993e8595e372839
+DIST stockfish-17.tar.gz 204647 BLAKE2B 1b8bc3cb18df67fb8d8c0a02284c47d06862ca33aacd894816be92f3c11976f5eb3a767adce92a27bcbc35abec3db04e3600fe046060fe61247850fe263d9aea SHA512 2736c7e78a30670704b4400e20a4a5bb5b07b2e3a14d19149eccea9ba45cda5b9b42034b1ae40ef1f49c87fc1b0bc1750e998ff732da8c5fe45dd8bdbf90f9cc
diff --git a/games-board/stockfish/stockfish-17.ebuild b/games-board/stockfish/stockfish-17.ebuild
new file mode 100644
index 000000000000..37f055b2abc6
--- /dev/null
+++ b/games-board/stockfish/stockfish-17.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILES="nn-1111cefa1111.nnue nn-37f18f62d772.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz"
+
+for i in $NNUE_FILES; do
+ SRC_URI+=" https://tests.stockfishchess.org/api/nn/${i} -> ${P}-${i}"
+done
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse cpu_flags_x86_avx512f
+ cpu_flags_x86_avx512dq debug general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ # remove config sanity check that doesn't like our COMPILER settings
+ sed -i -e 's/ config-sanity//g' Makefile || die
+
+ for i in $NNUE_FILES; do
+ cp "${DISTDIR}"/${P}-${i} ${i} || die "copying the nnue file failed"
+ done
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+
+ # Makefile is a bit optimistic
+ sed -e 's:-flto=full:-flto:g' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # avx512
+ # we currently can't express 'avx512vnni' 'avx512dq' 'avx512f' 'avx512bw' 'avx512vl'
+ # so only enable basic support
+ use cpu_flags_x86_avx512f && use cpu_flags_x86_avx512dq && my_arch=x86-64-avx512
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # There's a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake profile-build ARCH="${my_arch}" \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}