summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-06-08 21:47:38 +0200
committerSam James <sam@gentoo.org>2022-06-16 17:30:32 +0100
commit8a1ee8cfa08e6ab4c23fbf4ab12348cb6ff4e891 (patch)
treebe4dc185e9e127d0aff1c18a62a3a239051ac9ab /games-emulation/mgba
parentdev-vcs/subversion: fix unquoted variable EPREFIX (diff)
downloadgentoo-8a1ee8cfa08e6ab4c23fbf4ab12348cb6ff4e891.tar.gz
gentoo-8a1ee8cfa08e6ab4c23fbf4ab12348cb6ff4e891.tar.bz2
gentoo-8a1ee8cfa08e6ab4c23fbf4ab12348cb6ff4e891.zip
games-emulation/mgba: fix unquoted variable BUILD_DIR
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/mgba')
-rw-r--r--games-emulation/mgba/mgba-0.9.2.ebuild8
-rw-r--r--games-emulation/mgba/mgba-0.9.3-r1.ebuild6
-rw-r--r--games-emulation/mgba/mgba-0.9.3.ebuild8
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild8
4 files changed, 15 insertions, 15 deletions
diff --git a/games-emulation/mgba/mgba-0.9.2.ebuild b/games-emulation/mgba/mgba-0.9.2.ebuild
index cef008e8c593..971993505d7e 100644
--- a/games-emulation/mgba/mgba-0.9.2.ebuild
+++ b/games-emulation/mgba/mgba-0.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -94,7 +94,7 @@ src_compile() {
src_install() {
if use qt5 ; then
- dobin ${BUILD_DIR}/qt/${PN}-qt
+ dobin "${BUILD_DIR}"/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
@@ -103,10 +103,10 @@ src_install() {
fi
if use sdl ; then
doman doc/${PN}.6
- newbin ${BUILD_DIR}/sdl/${PN} ${PN}-sdl
+ newbin "${BUILD_DIR}"/sdl/${PN} ${PN}-sdl
fi
- dolib.so ${BUILD_DIR}/lib${PN}.so*
+ dolib.so "${BUILD_DIR}"/lib${PN}.so*
}
pkg_preinst() {
diff --git a/games-emulation/mgba/mgba-0.9.3-r1.ebuild b/games-emulation/mgba/mgba-0.9.3-r1.ebuild
index 92f2ac4813da..8ac2d817bb04 100644
--- a/games-emulation/mgba/mgba-0.9.3-r1.ebuild
+++ b/games-emulation/mgba/mgba-0.9.3-r1.ebuild
@@ -98,7 +98,7 @@ src_compile() {
src_install() {
if use qt5 ; then
- dobin ${BUILD_DIR}/qt/${PN}-qt
+ dobin "${BUILD_DIR}"/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
@@ -107,10 +107,10 @@ src_install() {
fi
if use sdl ; then
doman doc/${PN}.6
- newbin ${BUILD_DIR}/sdl/${PN} ${PN}-sdl
+ newbin "${BUILD_DIR}"/sdl/${PN} ${PN}-sdl
fi
- dolib.so ${BUILD_DIR}/lib${PN}.so*
+ dolib.so "${BUILD_DIR}"/lib${PN}.so*
}
pkg_preinst() {
diff --git a/games-emulation/mgba/mgba-0.9.3.ebuild b/games-emulation/mgba/mgba-0.9.3.ebuild
index e9baa50b1056..bfc1bea7e039 100644
--- a/games-emulation/mgba/mgba-0.9.3.ebuild
+++ b/games-emulation/mgba/mgba-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ src_compile() {
src_install() {
if use qt5 ; then
- dobin ${BUILD_DIR}/qt/${PN}-qt
+ dobin "${BUILD_DIR}"/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
@@ -103,10 +103,10 @@ src_install() {
fi
if use sdl ; then
doman doc/${PN}.6
- newbin ${BUILD_DIR}/sdl/${PN} ${PN}-sdl
+ newbin "${BUILD_DIR}"/sdl/${PN} ${PN}-sdl
fi
- dolib.so ${BUILD_DIR}/lib${PN}.so*
+ dolib.so "${BUILD_DIR}"/lib${PN}.so*
}
pkg_preinst() {
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index e9baa50b1056..bfc1bea7e039 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ src_compile() {
src_install() {
if use qt5 ; then
- dobin ${BUILD_DIR}/qt/${PN}-qt
+ dobin "${BUILD_DIR}"/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
@@ -103,10 +103,10 @@ src_install() {
fi
if use sdl ; then
doman doc/${PN}.6
- newbin ${BUILD_DIR}/sdl/${PN} ${PN}-sdl
+ newbin "${BUILD_DIR}"/sdl/${PN} ${PN}-sdl
fi
- dolib.so ${BUILD_DIR}/lib${PN}.so*
+ dolib.so "${BUILD_DIR}"/lib${PN}.so*
}
pkg_preinst() {