summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-05-14 13:45:03 -0700
committerSam James <sam@gentoo.org>2024-06-18 11:19:48 +0100
commit66cbadede80bd1db2f685c29c51de2e862a246f5 (patch)
tree00d186ce7c6e05807ec0edcfa1f31617ce56d994 /games-emulation
parentgames-emulation/melonds-jg: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-66cbadede80bd1db2f685c29c51de2e862a246f5.tar.gz
gentoo-66cbadede80bd1db2f685c29c51de2e862a246f5.tar.bz2
gentoo-66cbadede80bd1db2f685c29c51de2e862a246f5.zip
games-emulation/sameboy-jg: add 0.16.5
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sameboy-jg/Manifest1
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
index a7466bb9989a..8a36de04178f 100644
--- a/games-emulation/sameboy-jg/Manifest
+++ b/games-emulation/sameboy-jg/Manifest
@@ -1 +1,2 @@
DIST sameboy-0.16.2.tar.bz2 3556441 BLAKE2B 0972cb8ba200d8ac95a3d66e3b671c1adeeea71eebb4202b1985f7f72edebd42886aac48040bf034dab8d93fd52d15165551ee8dfaf6870a59ca7f574fc99e0f SHA512 bd456e248ec2d6ea0e8b017b705c829c6a94b1f7fe734769a86774c4b6983278cc5b4d61fdf8164844545bbd250b3c4f1fe725046ac7edb301268291d907f39f
+DIST sameboy-0.16.5.tar.bz2 4143349 BLAKE2B e56df9bd38a550a78a0f30ab0259b3b11e7af4bc14f0c8a7a51de34af49eac40f09c57b54ce5640ee697eaf8a3b586d0390bebc6f25ddf44ced4a65c7b8f3476 SHA512 e0f463f77236196e00834aa0e814e4cfe78947da73310bb37c23e5a0a7644015467c646825971c0ef6b10c7ba8c058589729271eeacf089ff6d5cad188f2c246
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
new file mode 100644
index 000000000000..c41503e9640a
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}