summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-11-18 09:42:49 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-12-02 21:26:45 +0000
commit8000446531b5ee1aa845243df463d70ca03ad456 (patch)
tree5ea167f84f7f542e72aa301e8c393e00a881f500 /games-engines/fheroes2
parentnet-proxy/squid: Stabilize 6.5 arm, #919054 (diff)
downloadgentoo-8000446531b5ee1aa845243df463d70ca03ad456.tar.gz
gentoo-8000446531b5ee1aa845243df463d70ca03ad456.tar.bz2
gentoo-8000446531b5ee1aa845243df463d70ca03ad456.zip
games-engines/fheroes2: add 1.0.10
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/fheroes2')
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.0.10.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 82ab0843ec58..8c4d787f6d3e 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
+DIST fheroes2-1.0.10.tar.gz 11810559 BLAKE2B 32e65a0763fc1b007152316e4453f818fb098f271e7038e18c7219221f3df64bb51e1b76086fa087d102dcd85bdf0e322bad6c5880fa86f235ebafbaf5d6155e SHA512 2510c5756b2a3c17b4eb560fb0d2bad900e9c268545f726a4f008a3153c9a6e9abb23c3586bb780cea65cfef3f3b05fe739cb717b30564d8cb886194effe2ec2
DIST fheroes2-1.0.9.tar.gz 11784935 BLAKE2B 0c85725f791615eb1f823f38cfc03a98a73d71d1c0dedeac2146f62099c25ed37bbd44c9d121099934f99850ad408c13c1ea1b51f531a2cc37a56d01a0beb826 SHA512 eeb575345a6250d60ed8c37ec66deec4f5383557d8259a6422ace84520321316016494d0cd6e8d5b57123f946f3841fc215183c297c9acefe17caa3e94123ea7
diff --git a/games-engines/fheroes2/fheroes2-1.0.10.ebuild b/games-engines/fheroes2/fheroes2-1.0.10.ebuild
new file mode 100644
index 000000000000..58080ed9163f
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.0.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}