summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quake1-teamfortress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quake1-teamfortress')
-rw-r--r--games-fps/quake1-teamfortress/Manifest2
-rw-r--r--games-fps/quake1-teamfortress/metadata.xml5
-rw-r--r--games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild37
3 files changed, 44 insertions, 0 deletions
diff --git a/games-fps/quake1-teamfortress/Manifest b/games-fps/quake1-teamfortress/Manifest
new file mode 100644
index 000000000000..fad750176e0f
--- /dev/null
+++ b/games-fps/quake1-teamfortress/Manifest
@@ -0,0 +1,2 @@
+DIST tf28.zip 4204316 SHA256 56a6767b7944f2ce54423f18f1cd59239ae37a7c7456f684227d6f5310c76291 SHA512 2b158982fbf501712fa31fae7b8d34ce4adf41c7ada7c32549bc94ea7370f56b7ebb03f08f70c38c4e53a4ba49a95cbd23acda39eddc4a360d236cc0129a3262 WHIRLPOOL aeeb5b1c8389b334cd630813e8969ab6a7af74ef13556e5667b65407479e03368649bf6300497a8963c30ed5b7d4fdb675d315749824a0fc21bd23f996402135
+DIST tf29qw.zip 626175 SHA256 85b24b677bbe3c6848949a90b06c5470dee40dab6db5f16c69472ba9d3194e4d SHA512 77ea488e5d9fcd3ad91317f2a35bd9e19ca38712cf9bf248bcfa88d1a5a66577ccc504476ecfb5d06bb7a28cd93ce92d3728f4be825c93567c8c2b61cb80c08d WHIRLPOOL f8acc7a45b991c3e15d2b2e1f667c9732f6ae239583bc823f2b1a3dddf6ce27e748991288a2618129f709e0a942d2030af2ccb4f598c0039223e1f4b96b6234c
diff --git a/games-fps/quake1-teamfortress/metadata.xml b/games-fps/quake1-teamfortress/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/quake1-teamfortress/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
new file mode 100644
index 000000000000..ccb0fd3e4466
--- /dev/null
+++ b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="The classic Team Fortress Quake World mod"
+HOMEPAGE="http://www.planetfortress.com/teamfortress/"
+SRC_URI="mirror://gentoo/tf28.zip
+ mirror://gentoo/tf29qw.zip"
+
+LICENSE="quake1-teamfortress"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ echo ">>> Unpacking tf28.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/tf28.zip || die "unpacking tf28.zip failed"
+ cd fortress
+ echo ">>> Unpacking tf29qw.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/tf29qw.zip || die "unpacking tf29qw.zip failed"
+
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg')
+ mv server.cfg server.example.cfg
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/quake1"
+ doins -r *
+ prepgamesdirs
+}