summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-28 15:32:05 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-28 15:36:27 -0400
commitb7deab8b7bc7d1579ee883d855a1cbcd0627b787 (patch)
tree60cfcc7afddfafef2a279c44ec84089a6471732f /games-puzzle/fbg/fbg-0.9-r3.ebuild
parentdev-ruby/eventmachine: skip fewer tests, backport OpenSSL 1.1.1 fixes (diff)
downloadgentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.tar.gz
gentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.tar.bz2
gentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.zip
games-puzzle/fbg: EAPI6->8, fix runtime
Haven't tried with it, but this likely been broken since gcc-8 or so. Also added --without-x so it doesn't try to link with libXt that it does not actually use. Closes: https://bugs.gentoo.org/815259 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/fbg/fbg-0.9-r3.ebuild')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r3.ebuild b/games-puzzle/fbg/fbg-0.9-r3.ebuild
new file mode 100644
index 000000000000..5da0c0508858
--- /dev/null
+++ b/games-puzzle/fbg/fbg-0.9-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Tetris clone written in OpenGL"
+HOMEPAGE="http://fbg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-games/physfs
+ media-libs/libmikmod
+ media-libs/libsdl[opengl,video]
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-return.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "/FBGDATADIR=/s|=.*|=\"${EPREFIX}/usr/share/${PN}\"|" \
+ -e '/^datadir=/d' \
+ -i configure || die
+}
+
+src_configure() {
+ econf --disable-fbglaunch --without-x
+}
+
+src_install() {
+ default
+
+ newicon startfbg/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Falling Block Game"
+
+ rm -r "${ED}"/usr/doc || die
+}