summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 18:16:17 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:35:02 +0200
commit3130c436aee0867e2d44d61deb975b30bf207fdb (patch)
treeeaba9b13c5bfd77a3527dc90593ea04c50aeb2df /games-puzzle
parentgames-puzzle/xtris: Drop old (diff)
downloadgentoo-3130c436aee0867e2d44d61deb975b30bf207fdb.tar.gz
gentoo-3130c436aee0867e2d44d61deb975b30bf207fdb.tar.bz2
gentoo-3130c436aee0867e2d44d61deb975b30bf207fdb.zip
games-puzzle/zaz: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/zaz/zaz-1.0.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..1ea20bafcd65
--- /dev/null
+++ b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="https://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 OFL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ local x=/usr/share/gettext/po/Makefile.in.in
+ [[ -e $x ]] && cp -f $x po/ #336119
+
+ eapply "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-libs -lvorbis
+ append-cflags $(pkg-config sdl --cflags)
+ append-cxxflags $(pkg-config sdl --cflags)
+ econf \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}