summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-06-22 21:19:45 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-06-22 21:19:45 +0100
commite2b9f0ceb1dbe7e236ac91fe9b71d1f11138df8f (patch)
tree4889d74bc4f78cd6fd07931b4c23706dea898af0 /games-util/acc
parentdev-python/namespace-repoze: arm64 stable (bug #727058) (diff)
downloadgentoo-e2b9f0ceb1dbe7e236ac91fe9b71d1f11138df8f.tar.gz
gentoo-e2b9f0ceb1dbe7e236ac91fe9b71d1f11138df8f.tar.bz2
gentoo-e2b9f0ceb1dbe7e236ac91fe9b71d1f11138df8f.zip
games-util/acc: New package
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/acc')
-rw-r--r--games-util/acc/Manifest1
-rw-r--r--games-util/acc/acc-1.57.ebuild30
-rw-r--r--games-util/acc/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/games-util/acc/Manifest b/games-util/acc/Manifest
new file mode 100644
index 000000000000..8ed92df6993a
--- /dev/null
+++ b/games-util/acc/Manifest
@@ -0,0 +1 @@
+DIST acc-1.57.tar.gz 70969 BLAKE2B 0c5d9f6778505881d9fa698da0958aea410a8d42f4b81c24277f59d0e9a601d44213e9399f0e693a210d0b935e57df4b6878fe1575005e5d573e19993404f570 SHA512 997bb6bb262743cacbf0606e7f6dcd00132a1f54eb24eddad92948c31ed552b3b678e72932150856fee57df2ab01fd25c29408f6c46a804614b883cf07532f3a
diff --git a/games-util/acc/acc-1.57.ebuild b/games-util/acc/acc-1.57.ebuild
new file mode 100644
index 000000000000..ca25dbd7690e
--- /dev/null
+++ b/games-util/acc/acc-1.57.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="ACS script compiler for use with ZDoom and Hexen"
+HOMEPAGE="https://zdoom.org/wiki/ACC"
+SRC_URI="https://github.com/rheit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Activision"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The Activision EULA is inappropriate but this was never resolved. :(
+# https://doomwiki.org/wiki/Raven_source_code_licensing
+RESTRICT="bindist mirror"
+
+src_configure() {
+ tc-export CC
+ append-cflags -Wall -Wextra
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.md
+
+ insinto /usr/share/${PN}
+ doins *.acs
+}
diff --git a/games-util/acc/metadata.xml b/games-util/acc/metadata.xml
new file mode 100644
index 000000000000..95907e587a83
--- /dev/null
+++ b/games-util/acc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rheit/acc</remote-id>
+ </upstream>
+</pkgmetadata>