summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/nautilus-share
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/nautilus-share')
-rw-r--r--gnome-extra/nautilus-share/Manifest2
-rw-r--r--gnome-extra/nautilus-share/metadata.xml9
-rw-r--r--gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild77
3 files changed, 88 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-share/Manifest b/gnome-extra/nautilus-share/Manifest
new file mode 100644
index 000000000000..d7bf88969086
--- /dev/null
+++ b/gnome-extra/nautilus-share/Manifest
@@ -0,0 +1,2 @@
+DIST nautilus-share_0.7.3-1.debian.tar.gz 9462 SHA256 691a6de3eb91475182850a0bd668cd5d01882fb4ae59921bb90f3e92344ed0cb SHA512 3f94e99510e26dddd348951825d07004e1195b37be45e11b38a4012764aa3b5558bd3f3b3693a07b474c0d31ce5c7152ac7ba359e44e97cf9acc940e19a3a337 WHIRLPOOL 9e21962f691da344a59d5530251f75e687322787f5be5a02f0b1b900acdc981b698f4c8fb99fba34db56cdd42b9ee79a121e51ea3399e32cba15dd89f0513c14
+DIST nautilus-share_0.7.3.orig.tar.bz2 319216 SHA256 5df9316bfbcda562b238b217d441dd5b08282d693cd205c53944d40fe89cf875 SHA512 b0d032a25a352ce1e1f5984e12ea4f842000b81700ec4fd1d08df5df5d178e71750817655a8b2f5789866153e35a70fb43a23fbfd4d391c809f3f16557571b47 WHIRLPOOL 4d5b49c01038ee7bd3e1a0a5e66ad640a9d5a18092f14b63e216162ef37f85d97d2e7f6329bdca0eb87d0f57ce74276908d10b5141745dd6b25d0f193348a1ba
diff --git a/gnome-extra/nautilus-share/metadata.xml b/gnome-extra/nautilus-share/metadata.xml
new file mode 100644
index 000000000000..5225cea25f55
--- /dev/null
+++ b/gnome-extra/nautilus-share/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild b/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..4e95f9304060
--- /dev/null
+++ b/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils user
+
+DESCRIPTION="A nautilus plugin to easily share folders over the SMB protocol"
+HOMEPAGE="http://gentoo.ovibes.net/nautilus-share http://packages.debian.org/unstable/nautilus-share"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/n/${PN}/${PN}_${PV}-1.debian.tar.gz"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND=">=dev-libs/glib-2.4:2
+ >=gnome-base/nautilus-2.10"
+RDEPEND="${COMMON_DEPEND}
+ net-fs/samba"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+USERSHARES_DIR="/var/lib/samba/usershare"
+USERSHARES_GROUP="samba"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/15_user-acl.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ keepdir ${USERSHARES_DIR}
+}
+
+pkg_postinst() {
+ enewgroup ${USERSHARES_GROUP}
+ einfo "Fixing ownership and permissions on ${EROOT}${USERSHARES_DIR#/}..."
+ chown root:${USERSHARES_GROUP} "${EROOT}"${USERSHARES_DIR#/}
+ chmod 01770 "${EROOT}"${USERSHARES_DIR#/}
+
+ einfo "To get nautilus-share working, add the lines"
+ einfo
+ einfo " # Allow users in group \"${USERSHARES_GROUP}\" to share"
+ einfo " # directories with the \"net usershare\" commands"
+ einfo " usershare path = \"${EROOT}${USERSHARES_DIR#/}\""
+ einfo " # Set a maximum of 100 user-defined shares in total"
+ einfo " usershare max shares = 100"
+ einfo " # Allow users to permit guest access"
+ einfo " usershare allow guests = yes"
+ einfo " # Only allow users to share directories they own"
+ einfo " usershare owner only = yes"
+ einfo
+ einfo "to the end of the [global] section in /etc/samba/smb.conf."
+ einfo
+ einfo "Users who are to be allowed to use nautilus-share should be added"
+ einfo "to the \"${USERSHARES_GROUP}\" group:"
+ einfo
+ einfo "# gpasswd -a USER ${USERSHARES_GROUP}"
+ einfo
+ einfo "Users may need to log out and in again for the group assignment to"
+ einfo "take effect and to restart Nautilus."
+ einfo
+ einfo "For more information, see USERSHARE in net(8)."
+}