summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-15 16:56:44 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-15 18:29:41 +0100
commitff00528acfa93080a49d063ed674844516305995 (patch)
tree6b55dce019cd3d1d64f6f6ea6ebdb262cd3e8307 /gnome-extra
parentsys-apps/baobab: drop 45.0 (diff)
downloadgentoo-ff00528acfa93080a49d063ed674844516305995.tar.gz
gentoo-ff00528acfa93080a49d063ed674844516305995.tar.bz2
gentoo-ff00528acfa93080a49d063ed674844516305995.zip
gnome-extra/gnome-weather: add 47.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/38684
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-47.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index e7ed0b16bab0..5dcfc21afc22 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,2 +1,3 @@
DIST gnome-weather-45.0.tar.xz 238520 BLAKE2B c1d11e63a01f59f07dab3b59e7b885970fdfefc74179c21afcce097ab7454e07754726f4676b1c9a49415d6a2312a73c4dbf4c0b378aaab741ccaa4146ab59b9 SHA512 decc1d917a9b0dcd4b9feb49c9dce0096f0f22b8da193bb3e913a92687b06f2cee9f7e029653b1af101d6ab682b49f89be37b864804e0f42ea0e249fc77a027c
DIST gnome-weather-46.0.tar.xz 239644 BLAKE2B 4acf901dbb7ee0240aa371797823c5d2eadfbc869b273e9bf0da45b311b71ea4977c6d0809f7067d79d80326d75c3c0184a463201c6f319573764277480ee23d SHA512 b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b
+DIST gnome-weather-47.0.tar.xz 252112 BLAKE2B 02d69555f66a36127f3d82e4bef3ccf531952544b100b564cf0dcf1eb508921cd052254fb512871c4b42af1f8d8ce87c77610ca941cc66475ee533c3a91840b1 SHA512 9ed6423a3eb68dcbbb5e1651e4c9af1e60897643d2d938812820c61520fe13b4d1a9049656ca4cc02c70d6c6c6511da0cb947c60859f53646fc1e75a4c52649b
diff --git a/gnome-extra/gnome-weather/gnome-weather-47.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-47.0.ebuild
new file mode 100644
index 000000000000..a0086b366148
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-47.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://apps.gnome.org/Weather/"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.4_alpha:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}