summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-03-25 14:24:04 -0400
committerJoonas Niilola <juippis@gentoo.org>2023-04-05 15:30:23 +0300
commit92f76473d225a0b5b141bd2c4477a57980dd7aad (patch)
treee1e4f3ebc1ea715e23be86c29e99f243584771bc /gui-apps/swappy/swappy-1.5.1.ebuild
parentapp-dicts/myspell-uk: add 6.1.0 (diff)
downloadgentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.tar.gz
gentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.tar.bz2
gentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.zip
gui-apps/swappy: add 1.5.1
Signed-off-by: Julien Roy <julien@jroy.ca> Closes: https://github.com/gentoo/gentoo/pull/30342 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps/swappy/swappy-1.5.1.ebuild')
-rw-r--r--gui-apps/swappy/swappy-1.5.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gui-apps/swappy/swappy-1.5.1.ebuild b/gui-apps/swappy/swappy-1.5.1.ebuild
new file mode 100644
index 000000000000..d2095c719603
--- /dev/null
+++ b/gui-apps/swappy/swappy-1.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ app-text/scdoc
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}