summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-18 23:51:09 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-09 12:09:28 +0200
commitbdf9318516cd94e98cc096df8bb83ca0a3ba169b (patch)
tree34566306b8044173a9a87f736e0dc71838ab6743 /gui-apps
parentdev-libs/gjs: update HOMEPAGE (diff)
downloadgentoo-bdf9318516cd94e98cc096df8bb83ca0a3ba169b.tar.gz
gentoo-bdf9318516cd94e98cc096df8bb83ca0a3ba169b.tar.bz2
gentoo-bdf9318516cd94e98cc096df8bb83ca0a3ba169b.zip
gui-apps/gnome-console: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36848 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/gnome-console/Manifest1
-rw-r--r--gui-apps/gnome-console/gnome-console-46.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/Manifest b/gui-apps/gnome-console/Manifest
index 4166a1dd6083..092db691a48f 100644
--- a/gui-apps/gnome-console/Manifest
+++ b/gui-apps/gnome-console/Manifest
@@ -1 +1,2 @@
DIST gnome-console-45.0.tar.xz 178444 BLAKE2B ca04c31657b19ab1651899c56ff64ffa6d3913935fa5564ba115d83ba6dec50d2b816a47064ab7538aaa07347ebcb1890cc7dcb6e29164f7a36a6e18985e874a SHA512 940f02b8e1b02a680d9c25de59f655243a033883b9e21a183bd40ebe09c1803d6fbbfb45223e9a4ae20401d65e80a2bf0ba28bc7971fe84889176be64062b8d0
+DIST gnome-console-46.0.tar.xz 185424 BLAKE2B 8a30519df47da40578a9cb493ce981518432377bce95f55f41326502d260dd8fdb1302fb1edc38847c51c4a8fb266fb87561a61eb9ebf21711d87ddfc654eafb SHA512 de885b23979278774d0211103b3b15d58c1d0224d59baa2dc8f9ab369b95f5d5fe659b3d2fddd1e10c5406c11b3c56e4c7ec41bb369cb149a5f975404ab98147
diff --git a/gui-apps/gnome-console/gnome-console-46.0.ebuild b/gui-apps/gnome-console/gnome-console-46.0.ebuild
new file mode 100644
index 000000000000..8c9a69b8384e
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-46.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.12.2:4
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=gui-libs/vte-0.75.1:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}