summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-18 10:22:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-18 10:23:11 -0500
commita104fefa6fd66d6728a583a4d6ad976bd1c7beeb (patch)
treef10f11c07458f0aeb73af2478438c0dd64fea488 /gui-libs
parentdev-libs/gmp: build w/ -std=gnu17 (diff)
downloadgentoo-a104fefa6fd66d6728a583a4d6ad976bd1c7beeb.tar.gz
gentoo-a104fefa6fd66d6728a583a4d6ad976bd1c7beeb.tar.bz2
gentoo-a104fefa6fd66d6728a583a4d6ad976bd1c7beeb.zip
gui-libs/egl-x11: add 1.0.0_pre20241113
Closes: https://bugs.gentoo.org/942396 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-x11/Manifest1
-rw-r--r--gui-libs/egl-x11/egl-x11-1.0.0_pre20241113.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/gui-libs/egl-x11/Manifest b/gui-libs/egl-x11/Manifest
index 7ab3b67d6f94..04e422865674 100644
--- a/gui-libs/egl-x11/Manifest
+++ b/gui-libs/egl-x11/Manifest
@@ -1 +1,2 @@
DIST egl-x11-1.0.0_pre20240919.tar.gz 71007 BLAKE2B 10793ee854f1548630772579a745c6d12c6add7abea506663b3c196726544353a06eb45a17a42f4fe1c13cb4602750f43d267c8c2be541c31fa34e9aa0f4c7a4 SHA512 b902e39107ec1e6fcd5d10a2741bcb1d3930b947d36c4778d5c3c12d14086d92ad64742f5a5ff2bdfd36c1cc37ac634277221272cb8f5092ff165fcc2c2ecdff
+DIST egl-x11-1.0.0_pre20241113.tar.gz 71112 BLAKE2B 991f9825feed3c873264047d324ba76893fa200c5c65705ed1ffda17e72feb50e397edee84ff77faac5e6d50272698557faeaee11f7e3eb8c7a111b27a53471e SHA512 624cb009ce2b920bab2b59b2ac27171e8988862d897125fa9dedfeb62ad075190eb94252f964828f094de069a1196314dcc89e6dd8222ed65f9fb95b32fb26be
diff --git a/gui-libs/egl-x11/egl-x11-1.0.0_pre20241113.ebuild b/gui-libs/egl-x11/egl-x11-1.0.0_pre20241113.ebuild
new file mode 100644
index 000000000000..bde11d7c5a36
--- /dev/null
+++ b/gui-libs/egl-x11/egl-x11-1.0.0_pre20241113.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+# no releases yet, update in sync with nvidia unless there is urgent fixes
+HASH_EGLX11=6092c1f6cff86702bbecedb918b214a5dca362f9
+
+DESCRIPTION="NVIDIA X11/XCB EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-x11/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-x11/archive/${HASH_EGLX11}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-${HASH_EGLX11}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# wrt blocker, may or may not cause problems if present with <560
+# drivers, and collides with <565.57.01-r2
+RDEPEND="
+ media-libs/mesa[gbm(+),${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ !<x11-drivers/nvidia-drivers-565.57.01-r2
+"
+DEPEND="
+ ${RDEPEND}
+ >=gui-libs/eglexternalplatform-1.2
+ media-libs/libglvnd
+ x11-base/xorg-proto
+"