summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-06 12:43:17 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-11 08:46:06 +0300
commita417f0ab12ef83a62cb70994f810696701112904 (patch)
tree6cccf59202b646e8d2cb08edb8b91e1b7b377264 /gui-wm
parentgui-libs/wlroots: drop USE=tinywl (diff)
downloadgentoo-a417f0ab12ef83a62cb70994f810696701112904.tar.gz
gentoo-a417f0ab12ef83a62cb70994f810696701112904.tar.bz2
gentoo-a417f0ab12ef83a62cb70994f810696701112904.zip
gui-wm/tinywl: new package (split from gui-libs/wlroots[tinywl]), add 0.17.3, 9999
wlroots is now slotted, USE=tinywl causes file collisions between slots split tinywl into its own package to avoid it. Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/37060 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/tinywl/Manifest1
-rw-r--r--gui-wm/tinywl/metadata.xml15
-rw-r--r--gui-wm/tinywl/tinywl-0.17.3.ebuild47
-rw-r--r--gui-wm/tinywl/tinywl-9999.ebuild47
4 files changed, 110 insertions, 0 deletions
diff --git a/gui-wm/tinywl/Manifest b/gui-wm/tinywl/Manifest
new file mode 100644
index 000000000000..a21edb849e46
--- /dev/null
+++ b/gui-wm/tinywl/Manifest
@@ -0,0 +1 @@
+DIST wlroots-0.17.3.tar.gz 608292 BLAKE2B 7caab3c3a58595d3a745c0b20a5db2193c54931cdd7bc1b9de11c151af82503a03a6a3166a86f42486cc69c6ac18ca2a5596809a5c5e6d7b44c9845f509c1093 SHA512 b88747daba304db6dc302acdebb8764e719d84134118963c019d5f0d0d38552e0ffd2a50bf560b3b84549c5a0f2d11a6187ac8ddcd9faa28c5b42f86c585b555
diff --git a/gui-wm/tinywl/metadata.xml b/gui-wm/tinywl/metadata.xml
new file mode 100644
index 000000000000..c478e8b9eaf9
--- /dev/null
+++ b/gui-wm/tinywl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>leohdz172@proton.me</email>
+ <name>Leonardo Hernández Hernández</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">wlroots/wlroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-wm/tinywl/tinywl-0.17.3.ebuild b/gui-wm/tinywl/tinywl-0.17.3.ebuild
new file mode 100644
index 000000000000..891403933f45
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-0.17.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}
diff --git a/gui-wm/tinywl/tinywl-9999.ebuild b/gui-wm/tinywl/tinywl-9999.ebuild
new file mode 100644
index 000000000000..891403933f45
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}