summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-09-10 00:11:08 -0700
committerYixun Lan <dlan@gentoo.org>2024-09-11 02:05:35 +0000
commitc8a43ef92a0dfe77fcce42c8a20c8fb276865d03 (patch)
tree0d4d6ac100e65a75af338ef9bab3080eae1d9d5a /gui-wm
parentgui-libs/aquamarine: add 0.4.1 (diff)
downloadgentoo-c8a43ef92a0dfe77fcce42c8a20c8fb276865d03.tar.gz
gentoo-c8a43ef92a0dfe77fcce42c8a20c8fb276865d03.tar.bz2
gentoo-c8a43ef92a0dfe77fcce42c8a20c8fb276865d03.zip
gui-wm/hyprland: add 0.43.0, sync live
Closes: https://bugs.gentoo.org/939391 Closes: https://github.com/gentoo/gentoo/pull/38545 Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.43.0.ebuild99
-rw-r--r--gui-wm/hyprland/hyprland-9999.ebuild1
3 files changed, 100 insertions, 1 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 95b80fb419cd..184e9bb82f16 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1 +1,2 @@
DIST hyprland-0.42.0.gh.tar.gz 54225438 BLAKE2B a947289c5568408d71383034a290f114b974f442ed1f56ac3ec30e49519ee886ac83e1f2611577a7240a555480a59bc01defb79b2aca2122ef0d81ea007f5486 SHA512 839916957abc867ad9a3a32b6f74830055060b99c4c1de314f71a85f8d55ef051c5adb7c79dd7a7e10f81d1130aa032458bb65ce2454198a79faa719021f66af
+DIST hyprland-0.43.0.gh.tar.gz 54388932 BLAKE2B 610afadde6e56cb576d96c1d704327534d3ab50e69b091e9b44e9f901dbdfcd38f8a3c6a40f7fd3e843e5dda884ea1e93a24e085446861104019be9489a0a666 SHA512 521adcfb9ef55d5ad45192566856c20619942e8229f41400d2534531458dd3e54673b9dd3a0c3360280ccaaf35f5ac48393553a8549f147b701aa26522cec37b
diff --git a/gui-wm/hyprland/hyprland-0.43.0.ebuild b/gui-wm/hyprland/hyprland-0.43.0.ebuild
new file mode 100644
index 000000000000..dbc6bd85587e
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.43.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ dev-build/meson
+ dev-vcs/git
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ >=dev-libs/wayland-1.20.0
+ gui-libs/aquamarine
+ >=gui-libs/hyprcursor-0.1.9
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ x11-libs/libXcursor
+ X? (
+ x11-libs/libxcb:0=
+ x11-base/xwayland
+ x11-libs/xcb-util-errors
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/hyprland-protocols-0.3
+ >=dev-libs/hyprlang-0.3.2
+ >=dev-libs/wayland-protocols-1.36
+ >=gui-libs/hyprutils-0.2.1
+"
+BDEPEND="
+ || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ app-misc/jq
+ dev-build/cmake
+ >=dev-util/hyprwayland-scanner-0.3.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 14 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-14 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
+ eerror "Hyprland requires >=sys-devel/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_prepare() {
+ # skip version.h
+ sed -i -e "s|scripts/generateVersion.sh|echo|g" meson.build || die
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ )
+
+ meson_src_configure
+}
diff --git a/gui-wm/hyprland/hyprland-9999.ebuild b/gui-wm/hyprland/hyprland-9999.ebuild
index 087e0987105b..31664e318dd9 100644
--- a/gui-wm/hyprland/hyprland-9999.ebuild
+++ b/gui-wm/hyprland/hyprland-9999.ebuild
@@ -28,7 +28,6 @@ HYPRPM_RDEPEND="
app-alternatives/ninja
dev-build/cmake
dev-build/meson
- dev-libs/libliftoff
dev-vcs/git
virtual/pkgconfig
"