summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-03 12:45:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-03 15:53:30 +0100
commitf5294cda382b239f7115dbfffcaf71ad0ed05b56 (patch)
tree9926866b9f6ddc783cf7aea6001a83b7bb47c72c /kde-apps/ffmpegthumbs
parentsys-libs/kpmcore: 21.12.3 version bump (diff)
downloadgentoo-f5294cda382b239f7115dbfffcaf71ad0ed05b56.tar.gz
gentoo-f5294cda382b239f7115dbfffcaf71ad0ed05b56.tar.bz2
gentoo-f5294cda382b239f7115dbfffcaf71ad0ed05b56.zip
kde-apps/ffmpegthumbs: Fix build with >=media-video/ffmpeg-5
See also: https://invent.kde.org/multimedia/ffmpegthumbs/-/merge_requests/16 Closes: https://bugs.gentoo.org/831480 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ffmpegthumbs')
-rw-r--r--kde-apps/ffmpegthumbs/ffmpegthumbs-21.12.3.ebuild4
-rw-r--r--kde-apps/ffmpegthumbs/files/ffmpegthumbs-21.12.3-ffmpeg5.patch28
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/ffmpegthumbs/ffmpegthumbs-21.12.3.ebuild b/kde-apps/ffmpegthumbs/ffmpegthumbs-21.12.3.ebuild
index e3f805e2feb0..0743bc755665 100644
--- a/kde-apps/ffmpegthumbs/ffmpegthumbs-21.12.3.ebuild
+++ b/kde-apps/ffmpegthumbs/ffmpegthumbs-21.12.3.ebuild
@@ -27,3 +27,7 @@ DEPEND="
media-video/ffmpeg:0=
"
RDEPEND="${DEPEND}"
+
+# Upstream pending MR:
+# https://invent.kde.org/multimedia/ffmpegthumbs/-/merge_requests/16
+PATCHES=( "${FILESDIR}/${P}-ffmpeg5.patch" ) # bug #831480
diff --git a/kde-apps/ffmpegthumbs/files/ffmpegthumbs-21.12.3-ffmpeg5.patch b/kde-apps/ffmpegthumbs/files/ffmpegthumbs-21.12.3-ffmpeg5.patch
new file mode 100644
index 000000000000..62322154eefb
--- /dev/null
+++ b/kde-apps/ffmpegthumbs/files/ffmpegthumbs-21.12.3-ffmpeg5.patch
@@ -0,0 +1,28 @@
+From 8c9491775a5af072bfbcf1a2fdfc1f016d1333cf Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Tue, 25 Jan 2022 12:53:45 +0100
+Subject: [PATCH] Fix build with FFmpeg 5
+
+---
+ ffmpegthumbnailer/moviedecoder.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/ffmpegthumbnailer/moviedecoder.h b/ffmpegthumbnailer/moviedecoder.h
+index 502abe9..03eb6dd 100644
+--- a/ffmpegthumbnailer/moviedecoder.h
++++ b/ffmpegthumbnailer/moviedecoder.h
+@@ -57,7 +57,11 @@ private:
+ int m_VideoStream;
+ AVFormatContext* m_pFormatContext;
+ AVCodecContext* m_pVideoCodecContext;
++#if LIBAVCODEC_VERSION_MAJOR < 59
+ AVCodec* m_pVideoCodec;
++#else
++ const AVCodec* m_pVideoCodec;
++#endif
+ AVStream* m_pVideoStream;
+ AVFrame* m_pFrame;
+ quint8* m_pFrameBuffer;
+--
+GitLab
+