summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-14 13:09:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-14 13:31:06 +0200
commit08d8404ec1fc80f94059d309386fcab9ee9d810c (patch)
tree8fec3fd4c11f4a43234bd8dbd862d14f432fed64 /kde-frameworks/frameworkintegration
parentgames-server/bedrock-server: drop 1.18.32.02 (diff)
downloadgentoo-08d8404ec1fc80f94059d309386fcab9ee9d810c.tar.gz
gentoo-08d8404ec1fc80f94059d309386fcab9ee9d810c.tar.bz2
gentoo-08d8404ec1fc80f94059d309386fcab9ee9d810c.zip
kde-frameworks/frameworkintegration: 5.94.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.94.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 8e3a40b592c0..703de0471d64 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.92.0.tar.xz 1758268 BLAKE2B 7f72908f93158f42c2e90488aa037bb7dd9146e333b504a9034c8b5c6898fb5a6357a62fc81c237f8be9b854d05c97ce4352d28aa4f28ba1674d26b0098c7e41 SHA512 3445749f4ee10493a798433a7b5630dc22701c98c3f81c7e2236cffea9f9576ce8123006e5123698e5d648771ea77bff848453b188b1a6e791aab08184cebecc
DIST frameworkintegration-5.93.0.tar.xz 1758280 BLAKE2B 9bc1d3e711ea548a561b81850e50c0e920b87cbf4a47506e1f4a7beca067030eaff50c857c59493198e98cf91673bc3e531fc35bc5c935573c8ba9d0202cb480 SHA512 679cecf3852965d0f746a44ece7ac993328d8133745c9c7a9afc05855e9f3497964a558e08d69b6baf7ca700b01611a1dd6c13d4ef145a3cd92b9459f5f753c0
+DIST frameworkintegration-5.94.0.tar.xz 1758292 BLAKE2B 00f4289667ff547e3064c3d18369a225825a08ec0569e5712a2c1b044d2ea1a4e9ff0a12a8e43d4c81900e5ae18f67ebbdc4b9589abb338fa2d8b6bdb2ed97ec SHA512 3900fe970d459707b634df90515e49593632e7fe1dc9ba2a54b45d5042a768997f11b0875fe5419912673d8c9166e244d27b943b83c2d4a8936b8d6e30e17eb1
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.94.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.94.0.ebuild
new file mode 100644
index 000000000000..1f7f33acb63e
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.94.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}