summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-11 20:57:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-11 21:14:43 +0100
commitb00a4a43237a3173732394de2fc0e8e38b402e7d (patch)
tree6f10497190d85e86300334a27dd09dce76b26b7f /kde-frameworks/frameworkintegration
parentmail-mta/exim-4.97.1-r3: update regex memory patch (diff)
downloadgentoo-b00a4a43237a3173732394de2fc0e8e38b402e7d.tar.gz
gentoo-b00a4a43237a3173732394de2fc0e8e38b402e7d.tar.bz2
gentoo-b00a4a43237a3173732394de2fc0e8e38b402e7d.zip
kde-frameworks/frameworkintegration: 5.115.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.115.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index cdb8851ee6f8..7b57f839e55e 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,4 @@
DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
DIST frameworkintegration-5.114.0.tar.xz 1760452 BLAKE2B 95b6ad13e185887e07ef04ba1eb696aac2d1ead3ff3b2d270044a07314b8532d5244ed23548582db852ae88b96fcbce728de6cc6fa4ccfe5467cfcc96ef1c953 SHA512 257d8b216053583c40a7586588f3ca0dff35e6240d1f222cfddc4c61c6c085a4e1ebde5a1a4bb59210db999a9fd932c3614cf8bcab6d40127413c0dc7f163e67
+DIST frameworkintegration-5.115.0.tar.xz 1760436 BLAKE2B 59127e732c3b1786e54a079315bf7d47b5025bd653348c67c167afdc2b6291ceb595d85f49c62cc080475fb0963851c07fd95aa2c344b8f0cc76610b701b5be8 SHA512 83cc9d4e1063cd1496dbe373f30f706dcb2ce2515735d7b82cd45cf35b20a8e6c51625b752c6e9a53033db1b0573f2f3159bd569becc707b3a2e7250ce7fd20a
DIST frameworkintegration-5.249.0.tar.xz 54200 BLAKE2B 34474f4b5cbe4a12b509591b477fb0db184bec60af7e0e4d6b53e2c4ed3cb54dc172b31810fb206aedf69aa9a6a3169c3000557ff06357bc261aee2d92109f98 SHA512 3f34f837481bb473075e4ab45dbe125015e88e7b03e5c785bb31926afec37ca2677b99e0ce16672120054f9007f1d668cfe95001c99fb7d40878986882c6d797
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.115.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.115.0.ebuild
new file mode 100644
index 000000000000..a35185a075f4
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.115.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}