summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/kwindowsystem
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwindowsystem')
-rw-r--r--kde-frameworks/kwindowsystem/Manifest1
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.61.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/Manifest b/kde-frameworks/kwindowsystem/Manifest
index 6b6fc98eb021..ed4a602ed2ca 100644
--- a/kde-frameworks/kwindowsystem/Manifest
+++ b/kde-frameworks/kwindowsystem/Manifest
@@ -1 +1,2 @@
DIST kwindowsystem-5.60.0.tar.xz 171080 BLAKE2B 2a6f348795d24236569ed5c21e2bc1c0f972b75b3009ae9f43612cfb854cea52ccfca92831b94f58a811e6e64da083707a3e69173a2d3626798edfe76b5858c1 SHA512 460a676fa0c0985979de19152bd61a7b8507b09d612ee693843ec586789845d4896bb240bc4cce51120f847f8564a85a31b0f7cef504091dec81bf6d18a99143
+DIST kwindowsystem-5.61.0.tar.xz 170864 BLAKE2B e56910de4acf490456784c62e2377159f2e1726b76a1b6a5d8c90459690ac329cef57aa0a88e970aee15e3725419e41c9104b10724889aeb083d20d7ea5b3ebd SHA512 f77ad4cbc92d4c9e85a608f341032aaa80a5fa9a94ad34ade0955bfcf4dec2b185b4fb1d6fc8c86832d15554e349f4bd1206e65830e0a0fcf285ef5aaf252807
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.61.0.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.61.0.ebuild
new file mode 100644
index 000000000000..fb8ed8357da1
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.61.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls X"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+DOCS=( docs/README.kstartupinfo )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}