summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-21 00:06:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-21 00:06:18 +0200
commitdf86b02fbdd7df50b76bdd9d5de27d1ae32a391d (patch)
tree2d791d2df3b17434275e69465b3dca4e645023f1 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.27.6 version bump (diff)
downloadgentoo-df86b02fbdd7df50b76bdd9d5de27d1ae32a391d.tar.gz
gentoo-df86b02fbdd7df50b76bdd9d5de27d1ae32a391d.tar.bz2
gentoo-df86b02fbdd7df50b76bdd9d5de27d1ae32a391d.zip
kde-plasma/ksshaskpass: 5.27.6 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index d931076543bf..b9efd2980ace 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.27.5.tar.xz 27928 BLAKE2B c4ce00f823bd99e9be8293c2f04293fc0046d60c61440a53e207a393a40d4262c5cf216d9749ba3eeecc974d25f194e2b573a19c50ded0835214caece8ad46aa SHA512 6e96894974d0b7309d360e5df6ef57608f52c9228f8cb0d34f8e7b3614111eeaa31d4225fa1299962985dc414e6980a8a7c5c42d0fc5d648696bfd8f222b149d
+DIST ksshaskpass-5.27.6.tar.xz 28008 BLAKE2B 868fe8f1755429d06fa9bc44b7d086cd7ac25c0ec838c44287f96c00017380666b2fa2d536fb244381ccdd4a0fa81fcf8822d2b9c053efce03f8aa910f3272f1 SHA512 78d37b37b6ae4c8e8b5ee90bcb8e440140684f1cfa318eed98e854016dc22bbd7edc3036776f778e5bc46c2859f5a4f44f6af7293368f98cff48575a7e37d050
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.6.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.6.ebuild
new file mode 100644
index 000000000000..1d6d755de2e8
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}