summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-22 18:25:38 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-22 19:56:36 +0100
commit5d535b3729cf0fda0de5a9015916bfe0f4fe2a42 (patch)
tree9f7d9e62530ec56703c116c0ff59b6853517b58b /kde-plasma/plasma-sdk
parentapp-crypt/pinentry: New upstream version 1.0.0 (diff)
downloadgentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.tar.gz
gentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.tar.bz2
gentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.zip
kde-plasma: Version bump KDE Plasma 5.8.4
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-plasma/plasma-sdk')
-rw-r--r--kde-plasma/plasma-sdk/Manifest1
-rw-r--r--kde-plasma/plasma-sdk/plasma-sdk-5.8.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-plasma/plasma-sdk/Manifest b/kde-plasma/plasma-sdk/Manifest
index 2c31448dbe3b..833071029539 100644
--- a/kde-plasma/plasma-sdk/Manifest
+++ b/kde-plasma/plasma-sdk/Manifest
@@ -1,2 +1,3 @@
DIST plasma-sdk-5.7.5.tar.xz 699380 SHA256 420bd69e91bc1ed3343ae8be5d088697f28c25a8371a76ea1aa997dab86fa11f SHA512 8c47a38658fbbaa5cb97725c6e96100158da361d829b4619f05163dfe1e88104368f7b3c718e2fc71429981ab34dd7284dabc9f9b4949119fbd6e311611a8b51 WHIRLPOOL 59700ba73f18718e264bae31e5cba685de5952c8e0aa71cc31507ffcafd0d438ac45bba9cc4a49e967b9975a593003e53c94c0147148773ff8bf737ca96696de
DIST plasma-sdk-5.8.3.tar.xz 716796 SHA256 a7666c9b9356e64fd653f6ef9d6fbdde143553166fe5cb9241a2a77a9c37fbc9 SHA512 7b36949e49097a317a553a262e7a425d4c4d35d2f26f6ddf0787ed4bd7e0dcb2c47ed8333fec481e6f7497821f67db7e2d9d8d855ba8a6cc5b94d609779e87ed WHIRLPOOL dad9b758c79d00e971516b2ffbcb2de17d6b5c4b735ab2003fbc2edff5d072494a8d1c0915fc627fedc85a838f1e15211f977819f225f48f64869c1c615bc957
+DIST plasma-sdk-5.8.4.tar.xz 723176 SHA256 491f81481b644f3ccf54d60718f3177e06e55fed11c6f192139bd012f6bd795a SHA512 f0e37c73f121ca8a994a9a7ededed4e93580ed4eae6ac701f5fe4dd3eab8b6107fd43a844d893918188cfc46d965f09502801e7194d0526ae32bfd2e0a765257 WHIRLPOOL 44d5ae3397168e285accb93003f67f16a6b968aa1e0759b0ee9cba74de0aaf8eb047a6e080306fce21546cb397f139eb485501ccda287559564d9479927c48e5
diff --git a/kde-plasma/plasma-sdk/plasma-sdk-5.8.4.ebuild b/kde-plasma/plasma-sdk/plasma-sdk-5.8.4.ebuild
new file mode 100644
index 000000000000..f2c060d46637
--- /dev/null
+++ b/kde-plasma/plasma-sdk/plasma-sdk-5.8.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Useful applications for Plasma development"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="plasmate"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/kirigami
+ plasmate? (
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_qt_dep qtwebkit)
+ dev-util/kdevplatform:5
+ )
+"
+RDEPEND="${DEPEND}
+ !dev-util/plasmate
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package plasmate KDevPlatform)
+ $(cmake-utils_use_find_package plasmate Qt5WebKit)
+ $(cmake-utils_use_find_package plasmate Qt5WebKitWidgets)
+ )
+
+ kde5_src_configure
+}