summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 20:27:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 22:03:59 +0100
commitfcb74f7a9abc5ce141cff2f11e9679dae116ca8e (patch)
tree6c97e0a1a4e0b368556d94cef320cd5bb6c4446f /kde-plasma
parentkde-plasma/kscreenlocker: 6.2.5 version bump (diff)
downloadgentoo-fcb74f7a9abc5ce141cff2f11e9679dae116ca8e.tar.gz
gentoo-fcb74f7a9abc5ce141cff2f11e9679dae116ca8e.tar.bz2
gentoo-fcb74f7a9abc5ce141cff2f11e9679dae116ca8e.zip
kde-plasma/ksshaskpass: 6.2.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.2.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 672ff6326605..615056ec5d37 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-6.2.4.tar.xz 30692 BLAKE2B 3d64823ca100068a8b90571a50afed299e12c3aa4083645aba3baba03a87f548863b41cabaac841356d00e1ce589a3428defa861b134acf8baa07330877c010e SHA512 78ae58b339e071293c2bbb82bb552f69fe173b0aff4a13adf85be193acda1222c1008772d1c0fe53663e5abcb4102ee1567f5b53c344e915d122c64dea2c9369
+DIST ksshaskpass-6.2.5.tar.xz 30732 BLAKE2B b9a1c9f0af750c8f757a30893ebd894d8930aea22985de653c8cf15504c4c7f13b63f7f3e70ccf34ff1f57ea90c4d322c3cfab0c57c3f45e3b1206fce89553a9 SHA512 f1ce7e8708646eefe08a06b365646118f7e8c237c1c324ed129fd07152bcbf6dd3078fd3d94356aac6738473399f4bd61cf2e8b594a9bbaabc352883a0f98ffe
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.2.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.2.5.ebuild
new file mode 100644
index 000000000000..24cc28174e67
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.2.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}