summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gif2apng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gif2apng')
-rw-r--r--media-gfx/gif2apng/Manifest4
-rw-r--r--media-gfx/gif2apng/files/gif2apng-1.8-flags.patch26
-rw-r--r--media-gfx/gif2apng/files/gif2apng-1.9-flags.patch15
-rw-r--r--media-gfx/gif2apng/gif2apng-1.6.ebuild31
-rw-r--r--media-gfx/gif2apng/gif2apng-1.7.ebuild31
-rw-r--r--media-gfx/gif2apng/gif2apng-1.8.ebuild35
-rw-r--r--media-gfx/gif2apng/gif2apng-1.9.ebuild35
-rw-r--r--media-gfx/gif2apng/metadata.xml8
8 files changed, 185 insertions, 0 deletions
diff --git a/media-gfx/gif2apng/Manifest b/media-gfx/gif2apng/Manifest
new file mode 100644
index 000000000000..f4ab14577f95
--- /dev/null
+++ b/media-gfx/gif2apng/Manifest
@@ -0,0 +1,4 @@
+DIST gif2apng-1.6-src.zip 8450 SHA256 1827b443f84319e8549c3235f2c3ac75b88e423bc0bf3218e658ad13b502537b
+DIST gif2apng-1.7-src.zip 8380 SHA256 3ceca8a421bdb6e4f1253a74d20b25cbaf484d8f62edc7f964b423c69d179996
+DIST gif2apng-1.8-src.zip 254365 SHA256 7ef4030dcfaaa5a0cba759d78d3b15c783902dce3aefeb1e8d7d5a6cfacbb639 SHA512 5a99e2b791b4a480c173d02d6360c4760a942b751907e9b3bf5a8db04b9c4a22872e62360f2c8253d1b3a0c5312931ff307175753fac798e3496588171fa8d4a WHIRLPOOL 1553e7c4fc98e21f3c33dc32822a0eb2c627d25357cf626a70aa9ddb59375ce758ce1201360eb31450e2d50f2951ccf5950b90f35a3ddfdd293917ca34bfce60
+DIST gif2apng-1.9-src.zip 258946 SHA256 3b21308e935d799b3ffb4a86c6e00ffa4cb9b3f72f52d58d51c66eb0574ae7d2 SHA512 6f161699aad949466c60e0fb6abb2f38e7ec8353dd15e65ccb9944a66dabc5a4acf32523cb64073c73290e54cc2b753db68123c14f3f7789343491a4f65dcd2c WHIRLPOOL 5e2058886505a89015f756c4d6a9e5f9e1a3efb74a8c754940fe79c6b9a00f54be416d2026bb7c8a3e918d051a5c7bb4681e21dfb0971d55e38f92ef5f04d631
diff --git a/media-gfx/gif2apng/files/gif2apng-1.8-flags.patch b/media-gfx/gif2apng/files/gif2apng-1.8-flags.patch
new file mode 100644
index 000000000000..fd8884a4dd05
--- /dev/null
+++ b/media-gfx/gif2apng/files/gif2apng-1.8-flags.patch
@@ -0,0 +1,26 @@
+--- gif2apng-1.8-src/Makefile
++++ gif2apng-1.8-src/Makefile
+@@ -11,19 +11,19 @@
+ all : $(PROG_NAME)
+
+ gif2apng : objdirs $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) -s -lstdc++ -lz
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJECTS) -lstdc++ -lz -lm
+
+ objdirs :
+ mkdir -p $(OBJ_DIRS)
+
+ obj/%.o : %.cpp
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) -O2 -Wall -pedantic -lz
++ $(CC) $(CFLAGS) -o $@ -c $< $(INCUDE_DIRS) -Wall -pedantic -lz -lm
+
+ obj/%.o : %.c
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) -O2 -Wall -pedantic -lz
++ $(CC) $(CFLAGS) -o $@ -c $< $(INCUDE_DIRS) -Wall -pedantic -lz -lm
+
+ obj/%.o : %.cc
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) -O2 -Wall -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses -lz
++ $(CC) $(CFLAGS) -o $@ -c $< $(INCUDE_DIRS) -Wall -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses -lz -lm
+
+ .PHONY : clean
+
diff --git a/media-gfx/gif2apng/files/gif2apng-1.9-flags.patch b/media-gfx/gif2apng/files/gif2apng-1.9-flags.patch
new file mode 100644
index 000000000000..0fe80eab8384
--- /dev/null
+++ b/media-gfx/gif2apng/files/gif2apng-1.9-flags.patch
@@ -0,0 +1,15 @@
+--- gif2apng-1.9-src/Makefile
++++ gif2apng-1.9-src/Makefile
+@@ -1,10 +1,9 @@
+ PACKAGE = gif2apng
+ CC = gcc
+ SRC_DIRS = . 7z zopfli
+-CFLAGS = -Wall -pedantic
+-CFLAGS_OPT = -O2
++CFLAGS += -Wall -pedantic
++CFLAGS_OPT =
+ CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
+-LDFLAGS = -s
+ LIBS = -lstdc++ -lm -lz
+
+ INCUDE_DIRS := $(addprefix -I./, $(SRC_DIRS))
diff --git a/media-gfx/gif2apng/gif2apng-1.6.ebuild b/media-gfx/gif2apng/gif2apng-1.6.ebuild
new file mode 100644
index 000000000000..02c481d62692
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/gif2apng/gif2apng-1.7.ebuild b/media-gfx/gif2apng/gif2apng-1.7.ebuild
new file mode 100644
index 000000000000..4b543baae601
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/gif2apng/gif2apng-1.8.ebuild b/media-gfx/gif2apng/gif2apng-1.8.ebuild
new file mode 100644
index 000000000000..e99d85a1ba68
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/gif2apng/gif2apng-1.9.ebuild b/media-gfx/gif2apng/gif2apng-1.9.ebuild
new file mode 100644
index 000000000000..f117e2e2715f
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/gif2apng/metadata.xml b/media-gfx/gif2apng/metadata.xml
new file mode 100644
index 000000000000..10f3816a1001
--- /dev/null
+++ b/media-gfx/gif2apng/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">gif2apng</remote-id>
+ </upstream>
+</pkgmetadata>