summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-05-19 00:12:35 +0300
committerSam James <sam@gentoo.org>2023-05-20 00:48:10 +0100
commitf49aca28f70a32e04b7049af2320c0793ba6168d (patch)
treef8ad09ce64abec89b6c244fecebe58820966b955 /media-gfx/gimp
parentmedia-gfx/gimp: 2.10.34-r2 bump, fix 'execinfo.h' not found (musl) (diff)
downloadgentoo-f49aca28f70a32e04b7049af2320c0793ba6168d.tar.gz
gentoo-f49aca28f70a32e04b7049af2320c0793ba6168d.tar.bz2
gentoo-f49aca28f70a32e04b7049af2320c0793ba6168d.zip
media-gfx/gimp: 2.10.34-r2, fix configure GCC13 implicit func. decl.
Closes: https://bugs.gentoo.org/899796 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/31087 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch24
-rw-r--r--media-gfx/gimp/gimp-2.10.34-r2.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
new file mode 100644
index 000000000000..a266fb94a996
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
@@ -0,0 +1,24 @@
+Gentoo issue: https://bugs.gentoo.org/899796
+
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1291,13 +1291,14 @@
+ #include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+- int main()
++ #include <stdlib.h>
++ int main(void)
+ {
+ int id;
+ char *shmaddr;
+- id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
+- if (id == -1)
+- exit (2);
++ id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
++ if (id == -1)
++ exit (2);
+ shmaddr = shmat (id, 0, 0);
+ shmctl (id, IPC_RMID, 0);
+ if ((char*) shmat (id, 0, 0) == (char*) -1)
diff --git a/media-gfx/gimp/gimp-2.10.34-r2.ebuild b/media-gfx/gimp/gimp-2.10.34-r2.ebuild
index f0bccadd7339..d01f0be4cba6 100644
--- a/media-gfx/gimp/gimp-2.10.34-r2.ebuild
+++ b/media-gfx/gimp/gimp-2.10.34-r2.ebuild
@@ -84,6 +84,7 @@ DOCS=( "AUTHORS" "ChangeLog" "HACKING" "NEWS" "README" "README.i18n" )
PATCHES=(
"${FILESDIR}/${PN}-2.10_fix_test-appdata.patch" # Bugs 685210 (and duplicate 691070)
"${FILESDIR}/${PN}-2.10_fix_musl_backtrace_backend_switch.patch" #900148
+ "${FILESDIR}/${PN}-2.10_fix_configure_GCC13_implicit_function_declarations.patch" #899796
)
src_prepare() {