summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pstoedit/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pstoedit/files')
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch13
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.60-parallel.patch49
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch54
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch14
4 files changed, 130 insertions, 0 deletions
diff --git a/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch b/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch
new file mode 100644
index 000000000000..279ed715f53a
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 6b33220..30c9f2e 100755
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -139,7 +139,7 @@ libpstoedit_la_SOURCES = \
+ genericints.h \
+ version.h
+
+-libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} -ldl -lm
++libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} ${LIBLD_LDFLAGS} -lm
+ libpstoedit_la_LDFLAGS = -no-undefined
+
+ pstoedit_SOURCES = cmdmain.cpp
diff --git a/media-gfx/pstoedit/files/pstoedit-3.60-parallel.patch b/media-gfx/pstoedit/files/pstoedit-3.60-parallel.patch
new file mode 100644
index 000000000000..0ad8c7cd9aa8
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.60-parallel.patch
@@ -0,0 +1,49 @@
+--- pstoedit-3.60/src/Makefile.am.orig
++++ pstoedit-3.60/src/Makefile.am
+@@ -87,6 +87,7 @@
+ $(sample_drivers_src)
+ libp2edrvstd_la_LIBADD=libpstoedit.la
+ libp2edrvstd_la_LDFLAGS=-no-undefined -module
++libp2edrvstd_la_DEPENDENCIES = libpstoedit.la
+
+ #libp2edrvplugins_la_SOURCES=drvmif.cpp drvcgm.cpp drvrtf.cpp drvwwmf.cpp
+ #libp2edrvplugins_la_LIBADD=
+@@ -96,25 +97,30 @@
+ libp2edrvlplot_la_SOURCES=drvlplot.cpp drvlplot.h initlibrary.cpp
+ libp2edrvlplot_la_LIBADD=$(LIBPLOTTER_LDFLAGS) libpstoedit.la
+ libp2edrvlplot_la_LDFLAGS=-no-undefined -module
++libp2edrvlplot_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvswf_la_SOURCES=drvswf.cpp drvswf.h initlibrary.cpp
+ libp2edrvswf_la_LIBADD=$(LIBMING_LDFLAGS) libpstoedit.la
+ libp2edrvswf_la_LDFLAGS=-no-undefined -module
++libp2edrvswf_la_DEPENDENCIES = libpstoedit.la
+
+ # note the __ stand for ++ - automake treats all no alphanums chars as _
+ libp2edrvmagick___la_SOURCES=drvmagick++.cpp drvmagick++.h initlibrary.cpp
+ libp2edrvmagick___la_LIBADD=${LIBMAGICK_LDFLAGS} libpstoedit.la
+ libp2edrvmagick___la_LDFLAGS=-no-undefined -module
++libp2edrvmagick___la_DEPENDENCIES = libpstoedit.la
+ # moved to configure.ac because needed only for g++ libp2edrvmagick___la_CPPFLAGS=$(LIBMAGICK_CFLAGS) $(AM_CPPFLAGS) -Wno-long-long
+
+ if USE_EMFBYSOURCE
+ libp2edrvwmf_la_SOURCES=emflib.cpp drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ else
+ libp2edrvwmf_la_SOURCES=drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=$(LIBEMF_LDFLAGS) libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ endif
+
+ libpstoedit_la_SOURCES = \
+@@ -139,6 +145,7 @@
+ pstoedit_SOURCES = cmdmain.cpp
+ pstoedit_LDADD = libpstoedit.la ${LIBLD_LDFLAGS}
+ pstoedit_LDFLAGS = -no-undefined
++pstoedit_DEPENDENCIES = libpstoedit.la
+
+ pkginclude_HEADERS = \
+ pstoedit.h \
diff --git a/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch b/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch
new file mode 100644
index 000000000000..e20324e2fd81
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.62-parallel.patch
@@ -0,0 +1,54 @@
+--- pstoedit-3.62.orig/src/Makefile.am
++++ pstoedit-3.62/src/Makefile.am
+@@ -92,6 +92,7 @@
+ $(sample_drivers_src)
+ libp2edrvstd_la_LIBADD=libpstoedit.la
+ libp2edrvstd_la_LDFLAGS=-no-undefined -module
++libp2edrvstd_la_DEPENDENCIES = libpstoedit.la
+
+ #libp2edrvplugins_la_SOURCES=drvmif.cpp drvcgm.cpp drvrtf.cpp drvwwmf.cpp
+ #libp2edrvplugins_la_LIBADD=
+@@ -101,29 +102,35 @@
+ libp2edrvlplot_la_SOURCES=drvlplot.cpp drvlplot.h initlibrary.cpp
+ libp2edrvlplot_la_LIBADD=$(LIBPLOTTER_LDFLAGS) libpstoedit.la
+ libp2edrvlplot_la_LDFLAGS=-no-undefined -module
++libp2edrvlplot_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvpptx_la_SOURCES=drvpptx.cpp drvpptx.h initlibrary.cpp
+ libp2edrvpptx_la_LIBADD=$(LIBPPTX_LDFLAGS) libpstoedit.la
+ libp2edrvpptx_la_LDFLAGS=-no-undefined -module
++libp2edrvpptx_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvswf_la_SOURCES=drvswf.cpp drvswf.h initlibrary.cpp
+ libp2edrvswf_la_LIBADD=$(LIBMING_LDFLAGS) libpstoedit.la
+ libp2edrvswf_la_LDFLAGS=-no-undefined -module
++libp2edrvswf_la_DEPENDENCIES = libpstoedit.la
+
+ # note the __ stand for ++ - automake treats all no alphanums chars as _
+ libp2edrvmagick___la_SOURCES=drvmagick++.cpp drvmagick++.h initlibrary.cpp
+ libp2edrvmagick___la_LIBADD=${LIBMAGICK_LDFLAGS} libpstoedit.la
+ libp2edrvmagick___la_LDFLAGS=-no-undefined -module
++libp2edrvmagick___la_DEPENDENCIES = libpstoedit.la
+ # moved to configure.ac because needed only for g++ libp2edrvmagick___la_CPPFLAGS=$(LIBMAGICK_CFLAGS) $(AM_CPPFLAGS) -Wno-long-long
+
+ if USE_EMFBYSOURCE
+ libp2edrvwmf_la_SOURCES=emflib.cpp drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ else
+ libp2edrvwmf_la_SOURCES=drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LIBADD=$(LIBEMF_LDFLAGS) libpstoedit.la
+ libp2edrvwmf_la_LDFLAGS=-no-undefined -module
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+ endif
+
+ libpstoedit_la_SOURCES = \
+@@ -148,6 +155,7 @@
+ pstoedit_SOURCES = cmdmain.cpp
+ pstoedit_LDADD = libpstoedit.la ${LIBLD_LDFLAGS}
+ pstoedit_LDFLAGS = -no-undefined
++pstoedit_DEPENDENCIES = libpstoedit.la
+
+ pkginclude_HEADERS = \
+ pstoedit.h \
diff --git a/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch b/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch
new file mode 100644
index 000000000000..c101077431e5
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.70-pkgconfig.patch
@@ -0,0 +1,14 @@
+LIBPNG_LDFLAGS is never substituted...
+https://bugs.gentoo.org/show_bug.cgi?id=551208
+
+Index: pstoedit-3.70/config/pstoedit.pc.in
+===================================================================
+--- pstoedit-3.70.orig/config/pstoedit.pc.in
++++ pstoedit-3.70/config/pstoedit.pc.in
+@@ -7,5 +7,5 @@ Name: pstoedit
+ Description: converts PostScript(TM) and PDF files to other vector graphic formats
+ Version: @VERSION@.0
+ Requires:
+-Libs: -L@libdir@ -lpstoedit @LIBPNG_LDFLAGS@ @CXX_STD_LIB@ @CXX_RUNTIME_LIB@ @LIBLD_LDFLAGS@
++Libs: -L@libdir@ -lpstoedit @CXX_STD_LIB@ @CXX_RUNTIME_LIB@ @LIBLD_LDFLAGS@
+ Cflags: -I@includedir@