summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 07:31:14 +0000
committerSam James <sam@gentoo.org>2022-12-18 07:46:35 +0000
commit7e249d8949fe06eca27f6fa1c2a517fc7cc87140 (patch)
tree37432c58930e66e800e02c33d6616f79b09e9b46 /media-gfx/rawtherapee
parentapp-editors/xemacs: fix revbump order (diff)
downloadgentoo-7e249d8949fe06eca27f6fa1c2a517fc7cc87140.tar.gz
gentoo-7e249d8949fe06eca27f6fa1c2a517fc7cc87140.tar.bz2
gentoo-7e249d8949fe06eca27f6fa1c2a517fc7cc87140.zip
media-gfx/rawtherapee: fix revbump order
Sorry for the noise. The script didn't get ordering right in all cases. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8-r2.ebuild75
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8-r3.ebuild (renamed from media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild)0
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.9-r1.ebuild (renamed from media-gfx/rawtherapee/rawtherapee-5.9.ebuild)11
3 files changed, 8 insertions, 78 deletions
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8-r2.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8-r2.ebuild
deleted file mode 100644
index dc930b95e291..000000000000
--- a/media-gfx/rawtherapee/rawtherapee-5.8-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P=${P/_rc/-rc}
-inherit cmake flag-o-matic toolchain-funcs xdg-utils
-
-DESCRIPTION="A powerful cross-platform raw image processing program"
-HOMEPAGE="https://www.rawtherapee.com/"
-SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="openmp tcmalloc"
-
-RDEPEND="
- dev-libs/expat
- dev-libs/libsigc++:2
- media-libs/lcms:2
- media-libs/lensfun
- media-libs/libcanberra[gtk3]
- media-libs/libiptcdata
- media-libs/libjpeg-turbo:=
- media-libs/libpng:0=
- media-libs/tiff:=
- sci-libs/fftw:3.0=
- sys-libs/zlib
- x11-libs/gtk+:3
- tcmalloc? ( dev-util/google-perftools )"
-DEPEND="${RDEPEND}
- dev-cpp/gtkmm:3.0
- gnome-base/librsvg"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- # upstream tested that "fast-math" give wrong results, so filter it
- # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
- filter-flags -ffast-math
- # -Ofast enable "fast-math" both in gcc and clang
- replace-flags -Ofast -O3
- # In case we add an ebuild for klt we can (i)use that one,
- # see http://cecas.clemson.edu/~stb/klt/
- local mycmakeargs=(
- -DOPTION_OMP=$(usex openmp)
- -DDOCDIR=/usr/share/doc/${PF}
- -DCREDITSDIR=/usr/share/${PN}
- -DLICENCEDIR=/usr/share/${PN}
- -DCACHE_NAME_SUFFIX=""
- -DWITH_SYSTEM_KLT="off"
- -DENABLE_TCMALLOC=$(usex tcmalloc)
- )
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8-r3.ebuild
index 0a49b2a46441..0a49b2a46441 100644
--- a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-5.8-r3.ebuild
diff --git a/media-gfx/rawtherapee/rawtherapee-5.9.ebuild b/media-gfx/rawtherapee/rawtherapee-5.9-r1.ebuild
index ce58450f30cb..29147172e67c 100644
--- a/media-gfx/rawtherapee/rawtherapee-5.9.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-5.9-r1.ebuild
@@ -16,8 +16,15 @@ KEYWORDS="~amd64 ~riscv ~x86"
IUSE="openmp tcmalloc"
RDEPEND="
+ dev-cpp/atkmm:=
+ dev-cpp/cairomm:=
+ dev-cpp/glibmm:=
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:=
dev-libs/expat
+ dev-libs/glib:=
dev-libs/libsigc++:2
+ gnome-base/librsvg
media-libs/lcms:2
media-libs/lensfun
media-libs/libcanberra[gtk3]
@@ -29,9 +36,7 @@ RDEPEND="
sys-libs/zlib
x11-libs/gtk+:3
tcmalloc? ( dev-util/google-perftools )"
-DEPEND="${RDEPEND}
- dev-cpp/gtkmm:3.0
- gnome-base/librsvg"
+DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"