summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/tachyon/tachyon-0.98.9-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/tachyon/tachyon-0.98.9-r2.ebuild')
-rw-r--r--media-gfx/tachyon/tachyon-0.98.9-r2.ebuild123
1 files changed, 123 insertions, 0 deletions
diff --git a/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild b/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild
new file mode 100644
index 000000000000..9bc8819bcb00
--- /dev/null
+++ b/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A portable, high performance parallel ray tracing system"
+HOMEPAGE="http://jedi.ks.uiuc.edu/~johns/raytracer/"
+SRC_URI="http://jedi.ks.uiuc.edu/~johns/raytracer/files/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~x64-macos ~x86-macos"
+IUSE="doc examples jpeg mpi +opengl png threads"
+
+CDEPEND="
+ jpeg? ( virtual/jpeg:0 )
+ mpi? ( virtual/mpi )
+ opengl? (
+ virtual/glu
+ virtual/opengl )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}"
+
+REQUIRED_USE="^^ ( opengl mpi )"
+
+S="${WORKDIR}/${PN}/unix"
+
+# TODO: Test on alpha, ia64, ppc
+# TODO: add other architectures
+# TODO: X, Motif, MBOX, Open Media Framework, Spaceball I/O, MGF ?
+
+TACHYON_MAKE_TARGET=
+
+pkg_setup() {
+ local ostarget
+ case ${CHOST} in
+ powerpc*-darwin*) ostarget=macosx ;;
+ *86*-darwin*) ostarget=macosx-x86 ;;
+ *) ostarget=linux ;;
+ esac
+
+ if use threads ; then
+ if use opengl ; then
+ TACHYON_MAKE_TARGET=${ostarget}-thr-ogl
+ elif use mpi ; then
+ TACHYON_MAKE_TARGET=${ostarget}-mpi-thr
+ else
+ TACHYON_MAKE_TARGET=${ostarget}-thr
+ fi
+
+ # TODO: Support for linux-athlon-thr ?
+ else
+ if use mpi ; then
+ TACHYON_MAKE_TARGET=${ostarget}-mpi
+ else
+ TACHYON_MAKE_TARGET=${ostarget}
+ fi
+ fi
+
+ if [[ -z "${TACHYON_MAKE_TARGET}" ]]; then
+ die "No target found, check use flags"
+ else
+ einfo "Using target: ${TACHYON_MAKE_TARGET}"
+ fi
+}
+
+src_prepare() {
+ if use jpeg ; then
+ sed -i \
+ -e "s:USEJPEG=:USEJPEG=-DUSEJPEG:g" \
+ -e "s:JPEGLIB=:JPEGLIB=-ljpeg:g" Make-config \
+ || die "sed failed"
+ fi
+
+ if use png ; then
+ sed -i \
+ -e "s:USEPNG=:USEPNG=-DUSEPNG:g" \
+ -e "s:PNGINC=:PNGINC=$(pkg-config libpng --cflags):g" \
+ -e "s:PNGLIB=:PNGLIB=$(pkg-config libpng --libs):g" Make-config \
+ || die "sed failed"
+ fi
+
+ if use mpi ; then
+ sed -i "s:MPIDIR=:MPIDIR=/usr:g" Make-config || die "sed failed"
+ sed -i "s:linux-lam:linux-mpi:g" Make-config || die "sed failed"
+ fi
+ sed -i \
+ -e "s:-O3::g;s:-g::g;s:-pg::g" \
+ -e "s:-m32:${CFLAGS}:g" \
+ -e "s:-m64:${CFLAGS}:g" \
+ -e "s:-ffast-math::g" \
+ -e "s:STRIP = strip:STRIP = touch:g" \
+ -e "s:CC = *cc:CC = $(tc-getCC):g" \
+ -e "s:-fomit-frame-pointer::g" Make-arch || die "sed failed"
+
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
+
+src_compile() {
+ emake ${TACHYON_MAKE_TARGET}
+}
+
+src_install() {
+ cd ..
+ dodoc Changes README
+
+ use doc && dohtml docs/tachyon/*
+
+ cd compile/${TACHYON_MAKE_TARGET}
+
+ dobin ${PN}
+
+ if use examples; then
+ cd "${S}/../scenes"
+ insinto "/usr/share/${PN}/examples"
+ doins *
+ fi
+}