summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Swanson <reiver@improbability.net>2024-07-30 16:23:10 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-08-05 10:34:42 +0300
commit973ecc31e61e26f69cc508250188b2dff5b910f6 (patch)
tree68188489bfd7533c10e0a7bca4c91b52d2ea0048 /media-gfx/zbar/files
parentapp-misc/broot: drop 1.36.1 (diff)
downloadgentoo-973ecc31e61e26f69cc508250188b2dff5b910f6.tar.gz
gentoo-973ecc31e61e26f69cc508250188b2dff5b910f6.tar.bz2
gentoo-973ecc31e61e26f69cc508250188b2dff5b910f6.zip
media-gfx/zbar: add 0.23.93 with python3_12 support
Closes: https://bugs.gentoo.org/929630 Signed-off-by: Alan Swanson <reiver@improbability.net> Closes: https://github.com/gentoo/gentoo/pull/37432 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/zbar/files')
-rw-r--r--media-gfx/zbar/files/zbar-0.23.93-configure-ac-do-not-use-hardcoded-pkg-config-command.patch49
-rw-r--r--media-gfx/zbar/files/zbar-0.23.93-configure-ac-use-old-way-to-detect-qt5.patch26
2 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/zbar/files/zbar-0.23.93-configure-ac-do-not-use-hardcoded-pkg-config-command.patch b/media-gfx/zbar/files/zbar-0.23.93-configure-ac-do-not-use-hardcoded-pkg-config-command.patch
new file mode 100644
index 000000000000..397ad6dd6fbf
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.93-configure-ac-do-not-use-hardcoded-pkg-config-command.patch
@@ -0,0 +1,49 @@
+From 368571ffa1a0f6cc41f708dd0d27f9b6e9409df8 Mon Sep 17 00:00:00 2001
+From: Boyuan Yang <byang@debian.org>
+Date: Tue, 9 Jan 2024 07:56:32 -0500
+Subject: [PATCH] configure.ac: Do not use hardcoded pkg-config command
+
+Use overridable $PKG_CONFIG instead.
+
+Also fixes some M4 grammar errors in configure.ac.
+
+Signed-off-by: Mauro Carvalho Chehab <mchehab@kernel.org>
+---
+ configure.ac | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f0f9723c..a2251e3d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -663,23 +663,23 @@ AC_ARG_WITH([qt6],
+
+ AS_IF([test "x$with_qt" != "xno"],
+ [AS_IF([test "x$with_qt6" != "xno"],
+- PKG_CHECK_MODULES([QT],
++ [PKG_CHECK_MODULES([QT],
+ [Qt6],
+- [MOC=`pkg-config Qt6 --variable=moc`
++ [MOC=`$PKG_CONFIG Qt6 --variable=moc`
+ QT_VERSION=`$PKG_CONFIG Qt6 --modversion`
+- QT6_HEADERS=`pkg-config Qt6 --variable=headerdir`
++ QT6_HEADERS=`$PKG_CONFIG Qt6 --variable=headerdir`
+ CPPFLAGS="$CPPFLAGS -I$QT6_HEADERS -I$QT6_HEADERS/QtWidgets -I$QT6_HEADERS/QtCore -I$QT6_HEADERS/QtGui"
+ qt_pkgconfig_file="zbar-qt5.pc"
+ ],
+- [with_qt6="no"]))
++ [with_qt6="no"])])
+ AS_IF([test "x$with_qt6" = "xno"],
+- PKG_CHECK_MODULES([QT],
++ [PKG_CHECK_MODULES([QT],
+ [Qt5Core >= 5 Qt5Gui >= 5 Qt5Widgets >= 5.0 Qt5X11Extras >= 5.0],
+- [MOC=`pkg-config Qt5 --variable=moc`
++ [MOC=`$PKG_CONFIG Qt5 --variable=moc`
+ QT_VERSION=`$PKG_CONFIG Qt5 --modversion`
+ qt_pkgconfig_file="zbar-qt5.pc"
+ ],
+- [with_qt="no"]))
++ [with_qt="no"])])
+ ])
+
+ AC_ARG_VAR([MOC], [full path to Qt moc program])
diff --git a/media-gfx/zbar/files/zbar-0.23.93-configure-ac-use-old-way-to-detect-qt5.patch b/media-gfx/zbar/files/zbar-0.23.93-configure-ac-use-old-way-to-detect-qt5.patch
new file mode 100644
index 000000000000..a5e9dba8ebea
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.93-configure-ac-use-old-way-to-detect-qt5.patch
@@ -0,0 +1,26 @@
+From a549566ea11eb03622bd4458a1728ffe3f589163 Mon Sep 17 00:00:00 2001
+From: Boyuan Yang <byang@debian.org>
+Date: Wed, 10 Jan 2024 10:57:29 -0500
+Subject: [PATCH] configure.ac: Use old way to detect Qt5
+
+Bug: https://github.com/mchehab/zbar/issues/277
+Signed-off-by: Mauro Carvalho Chehab <mchehab@kernel.org>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a2251e3d..0e5641e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -675,8 +675,8 @@ AS_IF([test "x$with_qt" != "xno"],
+ AS_IF([test "x$with_qt6" = "xno"],
+ [PKG_CHECK_MODULES([QT],
+ [Qt5Core >= 5 Qt5Gui >= 5 Qt5Widgets >= 5.0 Qt5X11Extras >= 5.0],
+- [MOC=`$PKG_CONFIG Qt5 --variable=moc`
+- QT_VERSION=`$PKG_CONFIG Qt5 --modversion`
++ [AC_CHECK_PROGS([MOC], [moc-qt5 moc])
++ QT_VERSION=`$PKG_CONFIG Qt5Gui --modversion`;
+ qt_pkgconfig_file="zbar-qt5.pc"
+ ],
+ [with_qt="no"])])