summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libcanberra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libcanberra')
-rw-r--r--media-libs/libcanberra/Manifest1
-rw-r--r--media-libs/libcanberra/files/libcanberra-0.30-wayland.patch64
-rw-r--r--media-libs/libcanberra/files/libcanberra-gtk-module.sh16
-rw-r--r--media-libs/libcanberra/libcanberra-0.30-r4.ebuild76
-rw-r--r--media-libs/libcanberra/libcanberra-0.30-r5.ebuild84
-rw-r--r--media-libs/libcanberra/metadata.xml32
6 files changed, 273 insertions, 0 deletions
diff --git a/media-libs/libcanberra/Manifest b/media-libs/libcanberra/Manifest
new file mode 100644
index 000000000000..ec2610dddead
--- /dev/null
+++ b/media-libs/libcanberra/Manifest
@@ -0,0 +1 @@
+DIST libcanberra-0.30.tar.xz 318960 SHA256 c2b671e67e0c288a69fc33dc1b6f1b534d07882c2aceed37004bf48c601afa72 SHA512 f7543582122256826cd01d0f5673e1e58d979941a93906400182305463d6166855cb51f35c56d807a56dc20b7a64f7ce4391368d24990c1b70782a7d0b4429c2 WHIRLPOOL 684f0c4886f5bbc22d92500d0aa6371655106c8e788fe57d98b011e61fc0b09412edfddf782d42424009445e66bfa28ec43953ad263ea3eb0d9d9049ec479d87
diff --git a/media-libs/libcanberra/files/libcanberra-0.30-wayland.patch b/media-libs/libcanberra/files/libcanberra-0.30-wayland.patch
new file mode 100644
index 000000000000..e51cfe00c0df
--- /dev/null
+++ b/media-libs/libcanberra/files/libcanberra-0.30-wayland.patch
@@ -0,0 +1,64 @@
+From c0620e432650e81062c1967cc669829dbd29b310 Mon Sep 17 00:00:00 2001
+From: Michael Meeks <michael.meeks@suse.com>
+Date: Fri, 09 Nov 2012 16:16:40 +0000
+Subject: gtk: Don't assume all GdkDisplays are GdkX11Displays: broadway/wayland
+
+---
+diff --git a/src/canberra-gtk-module.c b/src/canberra-gtk-module.c
+index 67791f0..c1532ab 100644
+--- a/src/canberra-gtk-module.c
++++ b/src/canberra-gtk-module.c
+@@ -307,6 +307,11 @@ static gint window_get_desktop(GdkDisplay *d, GdkWindow *w) {
+ guchar *data = NULL;
+ gint ret = -1;
+
++#ifdef GDK_IS_X11_DISPLAY
++ if (!GDK_IS_X11_DISPLAY(d))
++ return 0;
++#endif
++
+ if (XGetWindowProperty(GDK_DISPLAY_XDISPLAY(d), GDK_WINDOW_XID(w),
+ gdk_x11_get_xatom_by_name_for_display(d, "_NET_WM_DESKTOP"),
+ 0, G_MAXLONG, False, XA_CARDINAL, &type_return,
+@@ -335,6 +340,11 @@ static gint display_get_desktop(GdkDisplay *d) {
+ guchar *data = NULL;
+ gint ret = -1;
+
++#ifdef GDK_IS_X11_DISPLAY
++ if (!GDK_IS_X11_DISPLAY(d))
++ return 0;
++#endif
++
+ if (XGetWindowProperty(GDK_DISPLAY_XDISPLAY(d), DefaultRootWindow(GDK_DISPLAY_XDISPLAY(d)),
+ gdk_x11_get_xatom_by_name_for_display(d, "_NET_CURRENT_DESKTOP"),
+ 0, G_MAXLONG, False, XA_CARDINAL, &type_return,
+@@ -365,6 +375,11 @@ static gboolean window_is_xembed(GdkDisplay *d, GdkWindow *w) {
+ gboolean ret = FALSE;
+ Atom xembed;
+
++#ifdef GDK_IS_X11_DISPLAY
++ if (!GDK_IS_X11_DISPLAY(d))
++ return FALSE;
++#endif
++
+ /* Gnome Panel applets are XEMBED windows. We need to make sure we
+ * ignore them */
+
+diff --git a/src/canberra-gtk.c b/src/canberra-gtk.c
+index 34446f5..08cb668 100644
+--- a/src/canberra-gtk.c
++++ b/src/canberra-gtk.c
+@@ -185,6 +185,11 @@ static gint window_get_desktop(GdkDisplay *d, GdkWindow *w) {
+ guchar *data = NULL;
+ gint ret = -1;
+
++#ifdef GDK_IS_X11_DISPLAY
++ if (!GDK_IS_X11_DISPLAY(d))
++ return 0;
++#endif
++
+ if (XGetWindowProperty(GDK_DISPLAY_XDISPLAY(d), GDK_WINDOW_XID(w),
+ gdk_x11_get_xatom_by_name_for_display(d, "_NET_WM_DESKTOP"),
+ 0, G_MAXLONG, False, XA_CARDINAL, &type_return,
+--
+cgit v0.9.2
diff --git a/media-libs/libcanberra/files/libcanberra-gtk-module.sh b/media-libs/libcanberra/files/libcanberra-gtk-module.sh
new file mode 100644
index 000000000000..63c16af71861
--- /dev/null
+++ b/media-libs/libcanberra/files/libcanberra-gtk-module.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+# to be sourced
+
+case "$SESSION" in
+ GNOME)
+ # Done by gnome-settings-daemon
+ ;;
+ *)
+ if [ -z "$GTK_MODULES" ] ; then
+ GTK_MODULES="canberra-gtk-module"
+ else
+ GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
+ fi
+ export GTK_MODULES
+ ;;
+esac
diff --git a/media-libs/libcanberra/libcanberra-0.30-r4.ebuild b/media-libs/libcanberra/libcanberra-0.30-r4.ebuild
new file mode 100644
index 000000000000..8771431299e9
--- /dev/null
+++ b/media-libs/libcanberra/libcanberra-0.30-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils systemd
+
+DESCRIPTION="Portable sound event library"
+HOMEPAGE="http://git.0pointer.net/libcanberra.git/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="alsa gnome gstreamer +gtk +gtk3 oss pulseaudio +sound tdb udev"
+
+COMMON_DEPEND="
+ dev-libs/libltdl:0
+ media-libs/libvorbis
+ alsa? (
+ media-libs/alsa-lib:=
+ udev? ( virtual/libudev:= ) )
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ gtk? (
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-2.20.0:2
+ x11-libs/libX11 )
+ gtk3? (
+ >=dev-libs/glib-2.32:2
+ x11-libs/gtk+:3
+ x11-libs/libX11 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
+ tdb? ( sys-libs/tdb:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome? (
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas )
+ sound? ( x11-themes/sound-theme-freedesktop )" # Required for index.theme wrt #323379
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="udev? ( alsa )"
+
+src_prepare() {
+ # gtk: Don't assume all GdkDisplays are GdkX11Displays: broadway/wayland (from 'master')
+ epatch "${FILESDIR}/${PN}-0.30-wayland.patch"
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable gstreamer) \
+ $(use_enable gtk) \
+ $(use_enable gtk3) \
+ $(use_enable tdb) \
+ $(use_enable udev) \
+ $(systemd_with_unitdir) \
+ --disable-lynx \
+ --disable-gtk-doc
+}
+
+src_install() {
+ # Disable parallel installation until bug #253862 is solved
+ MAKEOPTS="${MAKEOPTS} -j1" default
+ prune_libtool_files --modules
+
+ # This is needed for desktops different than GNOME, bug #520550
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/libcanberra-gtk-module.sh 40-libcanberra-gtk-module
+}
diff --git a/media-libs/libcanberra/libcanberra-0.30-r5.ebuild b/media-libs/libcanberra/libcanberra-0.30-r5.ebuild
new file mode 100644
index 000000000000..25a60dae4cc9
--- /dev/null
+++ b/media-libs/libcanberra/libcanberra-0.30-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools-multilib eutils systemd
+
+DESCRIPTION="Portable sound event library"
+HOMEPAGE="http://git.0pointer.net/libcanberra.git/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="alsa gnome gstreamer +gtk +gtk3 oss pulseaudio +sound tdb udev"
+
+COMMON_DEPEND="
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ media-libs/libvorbis[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib:=[${MULTILIB_USEDEP}]
+ udev? ( virtual/libudev:=[${MULTILIB_USEDEP}] ) )
+ gstreamer? ( media-libs/gstreamer:1.0[${MULTILIB_USEDEP}] )
+ gtk? (
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.20.0:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}] )
+ gtk3? (
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.11[${MULTILIB_USEDEP}] )
+ tdb? ( sys-libs/tdb:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome? (
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas )
+ sound? ( x11-themes/sound-theme-freedesktop )" # Required for index.theme wrt #323379
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="udev? ( alsa )"
+
+src_prepare() {
+ # gtk: Don't assume all GdkDisplays are GdkX11Displays: broadway/wayland (from 'master')
+ epatch "${FILESDIR}/${PN}-0.30-wayland.patch"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable gstreamer) \
+ $(use_enable gtk) \
+ $(use_enable gtk3) \
+ $(use_enable tdb) \
+ $(use_enable udev) \
+ $(systemd_with_unitdir) \
+ --disable-lynx \
+ --disable-gtk-doc
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/gtkdoc/html gtkdoc/html || die
+ fi
+}
+
+multilib_src_install() {
+ # Disable parallel installation until bug #253862 is solved
+ emake DESTDIR="${D}" -j1 install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+
+ # This is needed for desktops different than GNOME, bug #520550
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/libcanberra-gtk-module.sh 40-libcanberra-gtk-module
+}
diff --git a/media-libs/libcanberra/metadata.xml b/media-libs/libcanberra/metadata.xml
new file mode 100644
index 000000000000..073731283aef
--- /dev/null
+++ b/media-libs/libcanberra/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>sound</herd>
+ <longdescription>
+ A small and lightweight implementation of the XDG Sound Theme Specification
+ (http://0pointer.de/public/sound-theme-spec.html)
+ </longdescription>
+ <use>
+ <flag name='alsa'>Enables ALSA sound driver.</flag>
+ <flag name='gstreamer'>Enables gstreamer sound driver. Not useful when
+ alsa or pulseaudio is available.</flag>
+ <flag name='gtk'>Enables building of gtk+ helper library, gtk+ runtime
+ sound effects and the canberra-gtk-play utility. To enable the gtk+
+ sound effects add canberra-gtk-module to the colon separated list of
+ modules in the GTK_MODULES environment variable.</flag>
+ <flag name='gtk3'>Enables building of gtk+3 helper library, gtk+3
+ runtime sound effects and the canberra-gtk-play utility. To enable
+ the gtk+3 sound effects add canberra-gtk-module to the colon
+ separated list of modules in the GTK_MODULES environment
+ variable.</flag>
+ <flag name='pulseaudio'>Enables PulseAudio sound driver that should be
+ able to support positional event sounds. This is the preferred
+ choice for best sound events experience and picked by default if
+ compiled in and possible to use at runtime.</flag>
+ <flag name='sound'>Install x11-themes/sound-theme-freedesktop to get
+ sounds on Gnome and Xfce.</flag>
+ <flag name='tdb'>Enables Trivial Database support for caching
+ purposes.</flag>
+ </use>
+</pkgmetadata>