summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libepoxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libepoxy')
-rw-r--r--media-libs/libepoxy/Manifest1
-rw-r--r--media-libs/libepoxy/libepoxy-1.2.ebuild43
-rw-r--r--media-libs/libepoxy/libepoxy-9999.ebuild43
-rw-r--r--media-libs/libepoxy/metadata.xml8
4 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/libepoxy/Manifest b/media-libs/libepoxy/Manifest
new file mode 100644
index 000000000000..fcc755633e83
--- /dev/null
+++ b/media-libs/libepoxy/Manifest
@@ -0,0 +1 @@
+DIST libepoxy-1.2.tar.gz 267110 SHA256 42c328440f60a5795835c5ec4bdfc1329e75bba16b6e22b3a87ed17e9679e8f6 SHA512 1104fc7e6cbb4bb95e422e7801491067806df6849690be4068b5eec33a5fc84672a5bb4666357e9a46d2fae436f83b37402b6cc0c4ee69627e48d48a4d32a2ed WHIRLPOOL 6a678b9999a909a858a6bd6d9695fd1b6093cd266c1b8c72c401c880a11c09aa9e819ec1459fd12e997ecf54460d7b1da0c476f79d27539218533fff53fc78a6
diff --git a/media-libs/libepoxy/libepoxy-1.2.ebuild b/media-libs/libepoxy/libepoxy-1.2.ebuild
new file mode 100644
index 000000000000..e52f15546a91
--- /dev/null
+++ b/media-libs/libepoxy/libepoxy-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+EGIT_REPO_URI="git://github.com/anholt/libepoxy.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='xml(+)'
+inherit autotools-multilib ${GIT_ECLASS} python-any-r1
+
+DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+if [[ ${PV} = 9999* ]]; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+ SRC_URI="https://github.com/anholt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTICT="test" # FIXME: tests fail when run from portage.
+
+DEPEND="${PYTHON_DEPS}
+ media-libs/mesa[egl]
+ x11-misc/util-macros
+ x11-libs/libX11"
+RDEPEND=""
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
diff --git a/media-libs/libepoxy/libepoxy-9999.ebuild b/media-libs/libepoxy/libepoxy-9999.ebuild
new file mode 100644
index 000000000000..882629e467ee
--- /dev/null
+++ b/media-libs/libepoxy/libepoxy-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+EGIT_REPO_URI="git://github.com/anholt/libepoxy.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='xml(+)'
+inherit autotools-multilib ${GIT_ECLASS} python-any-r1
+
+DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+if [[ ${PV} = 9999* ]]; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+ SRC_URI="https://github.com/anholt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTICT="test" # FIXME: tests fail when run from portage.
+
+DEPEND="${PYTHON_DEPS}
+ media-libs/mesa[egl]
+ x11-misc/util-macros
+ x11-libs/libX11"
+RDEPEND=""
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
diff --git a/media-libs/libepoxy/metadata.xml b/media-libs/libepoxy/metadata.xml
new file mode 100644
index 000000000000..8f185a37f13b
--- /dev/null
+++ b/media-libs/libepoxy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>x11</herd>
+ <upstream>
+ <remote-id type="github">anholt/libepoxy</remote-id>
+ </upstream>
+</pkgmetadata>