summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/vo-aacenc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/vo-aacenc')
-rw-r--r--media-libs/vo-aacenc/Manifest2
-rw-r--r--media-libs/vo-aacenc/metadata.xml12
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.2.ebuild50
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild42
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-9999.ebuild42
5 files changed, 148 insertions, 0 deletions
diff --git a/media-libs/vo-aacenc/Manifest b/media-libs/vo-aacenc/Manifest
new file mode 100644
index 000000000000..4b9679faccc1
--- /dev/null
+++ b/media-libs/vo-aacenc/Manifest
@@ -0,0 +1,2 @@
+DIST vo-aacenc-0.1.2.tar.gz 599983 SHA256 d1911edba77f0406aa45ef630cdf340a4f35fd42e1d37a6e3ee01365d86f3959 SHA512 28eb60656738c205b3e7734b997691246b6786d4a11ff6ad32d6e2b512cc0c8ddaeec352f69bc7006923a9b66c90fb9b8679bb52d9954cb3152f4aa780051427 WHIRLPOOL 8390428255d61daa4b9fe9b9233cacb45ec89a34761995cf6ebb88803883e6cbfade492a204aae96abb392d6cf7613c9bb12dc3318ef2fb5c19aa84aafb40ba8
+DIST vo-aacenc-0.1.3.tar.gz 612463 SHA256 e51a7477a359f18df7c4f82d195dab4e14e7414cbd48cf79cc195fc446850f36 SHA512 c8f00dfa758270ba9cad35dd6e24905dc7cf33d7717454b7c2c56c40dbf54f682450aa010a410a0350d70119d2aaa2e5ba4471b5bbe05ccec1f9d20ab3e57853 WHIRLPOOL 92a969fca0f2ab6758cb6d2a0f7e56991ceeb3ff6c1d68d7731008c3c31ebdaa222211d6153b6a125ddbcc529f65652ce64d902d6a533d3d3782946f764c76a3
diff --git a/media-libs/vo-aacenc/metadata.xml b/media-libs/vo-aacenc/metadata.xml
new file mode 100644
index 000000000000..4e08d8ecdfd1
--- /dev/null
+++ b/media-libs/vo-aacenc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">VisualOn AAC encoder library This library contains an encoder implementation
+of the Advanced Audio Coding (AAC) audio codec. The library is based on
+a codec implementation by VisualOn, part of the Stagefright framework from
+the Google Android project.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">opencore-amr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.2.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.2.ebuild
new file mode 100644
index 000000000000..78906f413dea
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="examples static-libs neon"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable neon armv7neon) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
new file mode 100644
index 000000000000..508ec2b6b858
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=yes
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="examples static-libs neon"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_configure() {
+ local myeconfargs=(
+ "$(use_enable examples example)"
+ "$(use_enable neon armv7neon)"
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/vo-aacenc/vo-aacenc-9999.ebuild b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
new file mode 100644
index 000000000000..ea5a6b290a6c
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=yes
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="examples static-libs neon"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_configure() {
+ local myeconfargs=(
+ "$(use_enable examples example)"
+ "$(use_enable neon armv7neon)"
+ )
+ autotools-multilib_src_configure
+}