summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2023-12-18 06:13:01 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-01-31 15:10:34 +0200
commitfcf9ee2d25254e1e838d83963f4e622fdbe582d4 (patch)
treed614e4c38866dbebfed9f7e5d8c30055483e7787 /media-libs/zita-resampler
parentnet-misc/connman-gtk: add missing Gtk+ type cast (diff)
downloadgentoo-fcf9ee2d25254e1e838d83963f4e622fdbe582d4.tar.gz
gentoo-fcf9ee2d25254e1e838d83963f4e622fdbe582d4.tar.bz2
gentoo-fcf9ee2d25254e1e838d83963f4e622fdbe582d4.zip
media-libs/zita-resampler: version bump to 1.11.2
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/zita-resampler')
-rw-r--r--media-libs/zita-resampler/Manifest1
-rw-r--r--media-libs/zita-resampler/files/zita-resampler-1.11.2-makefile.patch86
-rw-r--r--media-libs/zita-resampler/zita-resampler-1.11.2.ebuild61
3 files changed, 148 insertions, 0 deletions
diff --git a/media-libs/zita-resampler/Manifest b/media-libs/zita-resampler/Manifest
index 58795071635d..914e8c304d61 100644
--- a/media-libs/zita-resampler/Manifest
+++ b/media-libs/zita-resampler/Manifest
@@ -1,2 +1,3 @@
DIST zita-resampler-1.10.1.tar.xz 118800 BLAKE2B b8871899b7e6cac9b46df3c45c5bb1d8e9c9edd41bcbc5944098d9c4eee2ff4e4d216f97b3bfa96ac43082b5333de26201d6cba9eaa152efd20e8c5017478391 SHA512 ba95286b0744df393194f4f94a8aad62f6c088cf80f6be71482ed55beef6503a9bab6644f2565b69002247611fcf0fb6561fc0072578466a0133311721b43cf5
+DIST zita-resampler-1.11.2.tar.xz 123452 BLAKE2B 627b309b38b238902b1cad2cb0963d0182f8f4cc4bc72efcd2b9ecc9810f019968c141e31ffb94110e8c4ca781e1c57b7d3393a3d4699b3f90873958b34ce47c SHA512 1598c9ead4bf858d3a11677c9512932077e1d0b83588682eba402820936fa1cfc5fe1112abbecd945469b4ae2f7a6f59938a5fbb0fdd79de3b0a3a73703b03dd
DIST zita-resampler-1.8.0.tar.bz2 131161 BLAKE2B 1ba5d255fff9c66e18e6177bc7e48a4710fdf54f58c07f162f8c8801f4f449b22dea9922645e7e33b70e07739c2b381176714e704f9840305f194f3c23d66de2 SHA512 adf1f465ac09104be5a02c1cf0f052a44b4c1a448312f3aca016a889e98cfcdebfded38f60300ad85d18ae03eadca7e8e95efb2875267bc36435ccfac881a8e7
diff --git a/media-libs/zita-resampler/files/zita-resampler-1.11.2-makefile.patch b/media-libs/zita-resampler/files/zita-resampler-1.11.2-makefile.patch
new file mode 100644
index 000000000000..a83c2a70db72
--- /dev/null
+++ b/media-libs/zita-resampler/files/zita-resampler-1.11.2-makefile.patch
@@ -0,0 +1,86 @@
+--- a/apps/Makefile 2023-02-17 12:27:32.000000000 +0300
++++ b/apps/Makefile 2023-02-19 15:19:08.513618954 +0300
+@@ -23,18 +23,17 @@ BINDIR ?= $(PREFIX)/bin
+ MANDIR ?= /usr/share/man/man1
+
+ VERSION = 1.10.1
+-CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\"
+-CXXFLAGS += -O2 -ffast-math -Wall
+-CXXFLAGS += -march=native
++CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\" -I ../source
++CXXFLAGS += -ffast-math -Wall
+
+
+-all: zresample zretune zresample.1.gz zretune.1.gz
++all: zresample zretune
+
+
+ ZRESAMPLE_O = zresample.o audiofile.o dither.o
+ zresample: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zresample: $(ZRESAMPLE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
+ $(ZRESAMPLE_O):
+ -include $(ZRESAMPLE_O:%.o=%.d)
+
+@@ -42,31 +41,24 @@ $(ZRESAMPLE_O):
+ ZRETUNE_O = zretune.o audiofile.o dither.o
+ zretune: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zretune: $(ZRETUNE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
+ $(ZRETUNE_O):
+ -include $(ZRETUNE_O:%.o=%.d)
+
+
+-zresample.1.gz: zresample.1
+- gzip -c zresample.1 > zresample.1.gz
+-
+-zretune.1.gz: zretune.1
+- gzip -c zretune.1 > zretune.1.gz
+-
+-
+ install: all
+ install -d $(DESTDIR)$(BINDIR)
+ install -d $(DESTDIR)$(MANDIR)
+ install -m 755 zresample $(DESTDIR)$(BINDIR)
+ install -m 755 zretune $(DESTDIR)$(BINDIR)
+- install -m 644 zresample.1.gz $(DESTDIR)$(MANDIR)
+- install -m 644 zretune.1.gz $(DESTDIR)$(MANDIR)
++ install -m 644 zresample.1 $(DESTDIR)$(MANDIR)
++ install -m 644 zretune.1 $(DESTDIR)$(MANDIR)
+
+ uninstall:
+ /bin/rm -f $(DESTDIR)$(BINDIR)/zresample
+ /bin/rm -f $(DESTDIR)$(BINDIR)/zretune
+- /bin/rm -f $(DESTDIR)$(MANDIR)/zresample.1.gz
+- /bin/rm -f $(DESTDIR)$(MANDIR)/zretune.1.gz
++ /bin/rm -f $(DESTDIR)$(MANDIR)/zresample.1
++ /bin/rm -f $(DESTDIR)$(MANDIR)/zretune.1
+
+ clean:
+ /bin/rm -f *~ *.o *.a *.d *.so *.gz zresample zretune
+--- a/source/Makefile 2023-02-17 12:27:32.000000000 +0300
++++ b/source/Makefile 2023-02-19 15:07:48.327102241 +0300
+@@ -31,10 +31,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+ DISTDIR = zita-resampler-$(VERSION)
+
+ CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
+-CPPFLAGS += -DENABLE_SSE2
+-#CPPFLAGS += -DENABLE_NEON
+-CXXFLAGS += -Wall -fPIC -O2 -ffast-math
+-CXXFLAGS += -march=native
++CXXFLAGS += -Wall -fPIC -ffast-math
+ LDFLAGS +=
+ LDLIBS +=
+
+@@ -49,6 +47,9 @@ ZITA-RESAMPLER_H = zita-resampler/resamp
+ zita-resampler/vresampler.h zita-resampler/cresampler.h
+
+
++$(ZITA-RESAMPLER_SO): $(ZITA-RESAMPLER_MIN)
++ ln -sf $(ZITA-RESAMPLER_MIN) $(ZITA-RESAMPLER_SO)
++
+ $(ZITA-RESAMPLER_MIN): $(ZITA-RESAMPLER_O)
+ $(CXX) -shared $(LDFLAGS) -Wl,-soname,$(ZITA-RESAMPLER_MAJ) -o $(ZITA-RESAMPLER_MIN) $(ZITA-RESAMPLER_O) $(ZITA-RESAMPLER_DEP)
+
diff --git a/media-libs/zita-resampler/zita-resampler-1.11.2.ebuild b/media-libs/zita-resampler/zita-resampler-1.11.2.ebuild
new file mode 100644
index 000000000000..f10622423cf7
--- /dev/null
+++ b/media-libs/zita-resampler/zita-resampler-1.11.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="C++ library for real-time resampling of audio signals"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
+SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 tools"
+
+RDEPEND="tools? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS="docs/."
+
+PATCHES=( "${FILESDIR}"/${PN}-1.11.2-makefile.patch )
+
+src_compile() {
+ tc-export CXX
+ # Code paths that uses intrinsics are not properly guarded by symbol checks
+ if use cpu_flags_x86_sse2 ; then
+ if tc-cpp-is-true "defined(__SSE2__)" ${CFLAGS} ${CXXFLAGS} ; then
+ append-cppflags "-DENABLE_SSE2"
+ else
+ ewarn "SSE2 support has been disabled automatically because the"
+ ewarn "compiler does not support corresponding intrinsics"
+ fi
+ elif use cpu_flags_arm_neon ; then
+ if tc-cpp-is-true "defined(__ARM_NEON__)" ${CFLAGS} ${CXXFLAGS} ; then
+ append-cppflags "-DENABLE_NEON"
+ else
+ ewarn "NEON support has been disabled automatically because the"
+ ewarn "compiler does not support corresponding intrinsics"
+ fi
+ fi
+
+ emake -C source
+ if use tools; then
+ emake -C apps
+ fi
+}
+
+src_install() {
+ local myemakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}/usr"
+ LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ emake -C source "${myemakeargs[@]}" install
+ if use tools; then
+ emake -C apps "${myemakeargs[@]}" install
+ fi
+
+ einstalldocs
+}