summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-05-13 16:50:45 +0200
committerMatt Turner <mattst88@gentoo.org>2024-06-05 16:01:31 -0400
commitca67cb916cc2772e9d046171f28c5435e171ed1b (patch)
treea4edc007eacfdcc5c48c3b49065cffee76cf3c8f /media-libs
parentmedia-libs/mesa: update USE=vaapi dependencies (diff)
downloadgentoo-ca67cb916cc2772e9d046171f28c5435e171ed1b.tar.gz
gentoo-ca67cb916cc2772e9d046171f28c5435e171ed1b.tar.bz2
gentoo-ca67cb916cc2772e9d046171f28c5435e171ed1b.zip
media-libs/mesa: update USE=vdpau dependencies
Update vaapi/gallium-vdpau to match meson.build. - add virgl - drop r300 https://gitlab.freedesktop.org/mesa/mesa/-/blob/mesa-24.1.0-r1/meson.build?ref_type=tags#L601 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-24.1.0-r1.ebuild10
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-24.1.0-r1.ebuild b/media-libs/mesa/mesa-24.1.0-r1.ebuild
index f9a1033ab2e3..1e0717ab75a1 100644
--- a/media-libs/mesa/mesa-24.1.0-r1.ebuild
+++ b/media-libs/mesa/mesa-24.1.0-r1.ebuild
@@ -218,11 +218,11 @@ pkg_pretend() {
if use vdpau; then
if ! use video_cards_d3d12 &&
- ! use video_cards_r300 &&
+ ! use video_cards_nouveau &&
! use video_cards_r600 &&
! use video_cards_radeonsi &&
- ! use video_cards_nouveau; then
- ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, r300, r600, radeonsi, or nouveau"
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, nouveau, r600, radeonsi, or virgl"
fi
fi
@@ -337,10 +337,10 @@ multilib_src_configure() {
fi
if use video_cards_d3d12 ||
- use video_cards_r300 ||
+ use video_cards_nouveau ||
use video_cards_r600 ||
use video_cards_radeonsi ||
- use video_cards_nouveau; then
+ use video_cards_virgl; then
emesonargs+=($(meson_feature vdpau gallium-vdpau))
else
emesonargs+=(-Dgallium-vdpau=disabled)
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 4c91e9ed0c28..ac812afd990b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -215,11 +215,11 @@ pkg_pretend() {
if use vdpau; then
if ! use video_cards_d3d12 &&
- ! use video_cards_r300 &&
+ ! use video_cards_nouveau &&
! use video_cards_r600 &&
! use video_cards_radeonsi &&
- ! use video_cards_nouveau; then
- ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, r300, r600, radeonsi, or nouveau"
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, nouveau, r600, radeonsi, or virgl"
fi
fi
@@ -334,10 +334,10 @@ multilib_src_configure() {
fi
if use video_cards_d3d12 ||
- use video_cards_r300 ||
+ use video_cards_nouveau ||
use video_cards_r600 ||
use video_cards_radeonsi ||
- use video_cards_nouveau; then
+ use video_cards_virgl; then
emesonargs+=($(meson_feature vdpau gallium-vdpau))
else
emesonargs+=(-Dgallium-vdpau=disabled)