summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 23:47:22 +0000
committerSam James <sam@gentoo.org>2022-12-21 23:52:00 +0000
commite37f1398f63db9f2a6fe4133599a7169f6780e38 (patch)
tree206eb3f9ccda8d38cd9f2f744a43a2fbffa9771d /media-libs
parentmedia-libs/gegl: fix -Wstrict-prototypes (diff)
downloadgentoo-e37f1398f63db9f2a6fe4133599a7169f6780e38.tar.gz
gentoo-e37f1398f63db9f2a6fe4133599a7169f6780e38.tar.bz2
gentoo-e37f1398f63db9f2a6fe4133599a7169f6780e38.zip
media-libs/gegl: fix build w/ libraw-0.21
Closes: https://bugs.gentoo.org/887421 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/files/gegl-0.4.40-libraw-0.21.patch26
-rw-r--r--media-libs/gegl/gegl-0.4.40-r1.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.4.40-libraw-0.21.patch b/media-libs/gegl/files/gegl-0.4.40-libraw-0.21.patch
new file mode 100644
index 000000000000..84d80d96503c
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.4.40-libraw-0.21.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/887421
+https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/133
+
+From ef71b865a301514fcd13f50d421942f7b6b92d5e Mon Sep 17 00:00:00 2001
+From: Chris Mayo <aklhfex@gmail.com>
+Date: Wed, 21 Dec 2022 19:32:02 +0000
+Subject: [PATCH] raw-load: make compatible with LibRaw 0.21.0
+
+imgdata.params.shot_select moved to imgdata.rawparams.shot_select
+https://github.com/LibRaw/LibRaw/blob/979160ff13/Changelog.txt#L182
+--- a/operations/external/raw-load.c
++++ b/operations/external/raw-load.c
+@@ -114,7 +114,11 @@ prepare (GeglOperation *operation)
+ g_warning ("raw-load: Error Initializing raw library");
+ else
+ {
++#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0, 21)
++ p->LibRaw->rawparams.shot_select = o->image_num;
++#else
+ p->LibRaw->params.shot_select = o->image_num;
++#endif
+
+ p->LibRaw->params.aber[0] = 1.0;
+ p->LibRaw->params.aber[2] = 1.0;
+--
+GitLab
diff --git a/media-libs/gegl/gegl-0.4.40-r1.ebuild b/media-libs/gegl/gegl-0.4.40-r1.ebuild
index bcb10baa5cb6..a84d7725a292 100644
--- a/media-libs/gegl/gegl-0.4.40-r1.ebuild
+++ b/media-libs/gegl/gegl-0.4.40-r1.ebuild
@@ -78,6 +78,7 @@ DOCS=( AUTHORS docs/ChangeLog docs/NEWS.adoc )
PATCHES=(
"${FILESDIR}"/${PN}-0.4.40-strict-prototypes.patch
+ "${FILESDIR}"/${PN}-0.4.40-libraw-0.21.patch
)
pkg_pretend() {