summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-15 23:19:43 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-15 23:21:58 +0100
commitebb40e30117e74cd6d0619c73f1dffce8317a0d8 (patch)
tree2360454f661ead0a946a81a09695c7a7f20fd1c8 /media-libs
parentsys-firmware/intel-microcode: add 20240813_p20240815 (diff)
downloadgentoo-ebb40e30117e74cd6d0619c73f1dffce8317a0d8.tar.gz
gentoo-ebb40e30117e74cd6d0619c73f1dffce8317a0d8.tar.bz2
gentoo-ebb40e30117e74cd6d0619c73f1dffce8317a0d8.zip
media-libs/libopenmpt: Bump to version 0.7.9
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libopenmpt/Manifest1
-rw-r--r--media-libs/libopenmpt/libopenmpt-0.7.9.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libopenmpt/Manifest b/media-libs/libopenmpt/Manifest
index 110ff1de625a..859db07567c0 100644
--- a/media-libs/libopenmpt/Manifest
+++ b/media-libs/libopenmpt/Manifest
@@ -1,3 +1,4 @@
DIST libopenmpt-0.6.6+release.autotools.tar.gz 1554516 BLAKE2B 21e2fc4252431235608a52d3a321e26eae5d45f2328ff3e3604d84c537d72e07d72346c504901b000af04dfc52b1dd91c79f576be4331ea8685e534a174b61cd SHA512 b634c556f13dc51d1008f4216936a9b7cab25a6fb0d5218da0b692ec848de21905ed1981223ac9ecdebea9ce6c5376e91ff92e1655dd0be491fce0114e3230bf
DIST libopenmpt-0.7.6+release.autotools.tar.gz 1652544 BLAKE2B 022686bbb13728da134017b16c70cb9f3b47d64b0b6a889f473b5b72b5aa5cb66b84953b414075b6e9842fea947eb67b6cff2ae1130618bd0c0840f90ce88e70 SHA512 9665d3e301bab06f363bc4376fc488ca5befcf05f580deeb01a035167f02f8d47cda0d940239d5f29a91f97da6f31a2f6f20836b4f8ef6a248c7e39e49a7aa66
DIST libopenmpt-0.7.7+release.autotools.tar.gz 1660204 BLAKE2B 4b6ee75036c97ac2dce7e66776b36df09847db2c482cb22b052569385c06eb954d1cfae5cb00d415a6b18fd11663b2af43c94361dc9c0c84595c0d530e2bb355 SHA512 88d68bd32e696c01c070abd7156645c2969d389d6fb660f4f45d9e5e16ff9c25c3084d30cef208578080ee8a2da5c6045e5b1d93db7e2c456d42b91daaa02199
+DIST libopenmpt-0.7.9+release.autotools.tar.gz 1669833 BLAKE2B 9ba6af6df794583748336cc977b20d7bdb3f8d75e32d32a420c5e137511352ea5ec41b31beb7b0df78376dcb0e3a8160a1c527b6f4575b61b945a9f93252fe84 SHA512 e0928d3dc439c3ed7296b97dc8b8e255db22bfd91fd3bc73d0bdca8262a5cb26dff0ba89e508a4443ebe34c34fc880b202a758a11fde31b75e1ebd5725819414
diff --git a/media-libs/libopenmpt/libopenmpt-0.7.9.ebuild b/media-libs/libopenmpt/libopenmpt-0.7.9.ebuild
new file mode 100644
index 000000000000..03b0016c8652
--- /dev/null
+++ b/media-libs/libopenmpt/libopenmpt-0.7.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+MY_P="libopenmpt-${PV}+release.autotools"
+DESCRIPTION="Library to decode tracked music files (modules)"
+HOMEPAGE="https://lib.openmpt.org/libopenmpt/"
+SRC_URI="https://lib.openmpt.org/files/libopenmpt/src/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="examples mp3 ogg static-libs test vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mp3? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )
+ vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # A lot of these optional dependencies relate to openmpt123, which
+ # we package separately, so we disable them here.
+ econf \
+ $(use_enable static-libs static) \
+ --disable-openmpt123 \
+ --disable-examples \
+ $(use_enable test tests) \
+ --disable-doxygen-doc \
+ $(use_with zlib) \
+ $(use_with mp3 mpg123) \
+ $(use_with ogg) \
+ $(use_with vorbis) \
+ $(use_with vorbis vorbisfile) \
+ --without-pulseaudio \
+ --without-portaudio \
+ --without-portaudiocpp \
+ --without-sdl2 \
+ --without-sndfile \
+ --without-flac
+}
+
+multilib_src_install_all() {
+ rm -f \
+ "${ED}"/usr/*/*.la \
+ "${ED}"/usr/share/doc/${P}/LICENSE || die
+
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${P}/examples || die
+ fi
+}