summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-vodcatcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-vodcatcher')
-rw-r--r--media-plugins/vdr-vodcatcher/Manifest1
-rw-r--r--media-plugins/vdr-vodcatcher/files/rc-addon.sh15
-rw-r--r--media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_gcc-4.7.patch15
-rw-r--r--media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_unbundle-tinyxml2.diff50
-rw-r--r--media-plugins/vdr-vodcatcher/metadata.xml10
-rw-r--r--media-plugins/vdr-vodcatcher/vdr-vodcatcher-0.2.2.ebuild50
6 files changed, 141 insertions, 0 deletions
diff --git a/media-plugins/vdr-vodcatcher/Manifest b/media-plugins/vdr-vodcatcher/Manifest
new file mode 100644
index 000000000000..cb999b73969e
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/Manifest
@@ -0,0 +1 @@
+DIST vdr-vodcatcher-0.2.2.tar.gz 126612 SHA256 85f728a5eecc5845d3bb18c97ff96c65ec2cb5653dcf24fb8be604d8c02adf32 SHA512 05a8188888caed5bd656d0ff65b718debdc889e82373b6e00aed4b2ffb942f822f8b6cbff4811d5f4c9b271e1ff8d8ec5874d34081b5ef3c8fc95ac215ce2a22 WHIRLPOOL 27e81685a588892e8f9b36573240ed4f3954c4617aceec6d8d2305f68669ff075da759d1b950802744b188dec41ee43e49841f3b137d8274f4ca4dc8d24d4cb8
diff --git a/media-plugins/vdr-vodcatcher/files/rc-addon.sh b/media-plugins/vdr-vodcatcher/files/rc-addon.sh
new file mode 100644
index 000000000000..2072cb268fe4
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/files/rc-addon.sh
@@ -0,0 +1,15 @@
+# $Id$
+#
+# rc-addon-script for plugin vodcatcher
+#
+# Joerg Bornkessel <hd_brummy@gentoo.org>
+
+VODCATCHER_CACHE_DIR=var/cache/vdr-plugin-vodcatcher
+
+# depends on QA, create paths in /var/cache on the fly at runtime as needed
+init_cache_dir() {
+ if [ ! -d "${VODCATCHER_CACHE_DIR}" ]; then
+ mkdir -p ${VODCATCHER_CACHE_DIR}
+ chown vdr:vdr ${VODCATCHER_CACHE_DIR}
+ fi
+}
diff --git a/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_gcc-4.7.patch b/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_gcc-4.7.patch
new file mode 100644
index 000000000000..8472764a8631
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_gcc-4.7.patch
@@ -0,0 +1,15 @@
+compilefix for gcc-4.7
+https://bugs.gentoo.org/show_bug.cgi?id=514128
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> 22/Jun/2014
+
+diff -Naur vodcatcher-0.2.2.orig/src/LocalFileCache.cc vodcatcher-0.2.2/src/LocalFileCache.cc
+--- vodcatcher-0.2.2.orig/src/LocalFileCache.cc 2014-06-22 00:34:55.448489644 +0200
++++ vodcatcher-0.2.2/src/LocalFileCache.cc 2014-06-22 00:36:11.090546002 +0200
+@@ -24,6 +24,7 @@
+ #include "LocalFileCache.h"
+ #include "SdbmHashCalculator.h"
+ #include <values.h>
++#include <unistd.h>
+
+ using namespace std;
+
diff --git a/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_unbundle-tinyxml2.diff b/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_unbundle-tinyxml2.diff
new file mode 100644
index 000000000000..0f79116cb346
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/files/vdr-vodcatcher-0.2.2_unbundle-tinyxml2.diff
@@ -0,0 +1,50 @@
+diff -Naur vodcatcher-0.2.2.orig/Makefile vodcatcher-0.2.2/Makefile
+--- vodcatcher-0.2.2.orig/Makefile 2010-09-22 21:51:06.000000000 +0200
++++ vodcatcher-0.2.2/Makefile 2010-09-22 21:53:11.000000000 +0200
+@@ -50,8 +50,7 @@
+ ### Includes and Defines (add further entries here):
+
+ INCLUDES += -I. -I$(VDRDIR)/include -I$(DVBDIR)/include
+-INCLUDES += `curl-config --cflags`
+-INCLUDES += -I./tinyxml
++INCLUDES += $(shell curl-config --cflags)
+
+ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+ DEFINES += -DCXXTEST_ABORT_TEST_ON_FAIL
+@@ -66,7 +65,8 @@
+ endif
+
+ # libcurl, libxml, libxml++
+-LIBS += `curl-config --libs`
++LIBS += -lcurl
++LIBS += -ltinyxml
+
+ ### The source files (add further files here):
+
+diff -Naur vodcatcher-0.2.2.orig/sources.mk vodcatcher-0.2.2/sources.mk
+--- vodcatcher-0.2.2.orig/sources.mk 2010-09-22 21:51:06.000000000 +0200
++++ vodcatcher-0.2.2/sources.mk 2010-09-22 21:53:22.000000000 +0200
+@@ -34,11 +34,6 @@
+ src/StreamType.cc \
+ src/SynchedDownloadPool.cc \
+ src/ThreadsafeDownloadPool.cc \
+- tinyxml/tinystr.cpp \
+- tinyxml/tinyxml.cpp \
+- tinyxml/tinyxmlerror.cpp \
+- tinyxml/tinyxmlparser.cpp \
+-
+
+ SRCS_TESTONLY = \
+ src/DownloadCacheMock.cc \
+diff -Naur vodcatcher-0.2.2.orig/src/RssFeedParser.cc vodcatcher-0.2.2/src/RssFeedParser.cc
+--- vodcatcher-0.2.2.orig/src/RssFeedParser.cc 2010-09-22 21:51:06.000000000 +0200
++++ vodcatcher-0.2.2/src/RssFeedParser.cc 2010-09-22 21:53:44.000000000 +0200
+@@ -22,7 +22,7 @@
+ #include "HtmlToText.h"
+ #include "Feed.h"
+ #include "IDownloadCache.h"
+-#include "tinyxml.h"
++#include <tinyxml.h>
+ #include "Item.h"
+
+ using namespace std;
diff --git a/media-plugins/vdr-vodcatcher/metadata.xml b/media-plugins/vdr-vodcatcher/metadata.xml
new file mode 100644
index 000000000000..5f9f14619db8
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-vodcatcher/vdr-vodcatcher-0.2.2.ebuild b/media-plugins/vdr-vodcatcher/vdr-vodcatcher-0.2.2.ebuild
new file mode 100644
index 000000000000..a9b8b5b01eae
--- /dev/null
+++ b/media-plugins/vdr-vodcatcher/vdr-vodcatcher-0.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Downloads rss-feeds and passes video enclosures to the mplayer plugin"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-vodcatcher"
+SRC_URI="mirror://vdr-developerorg/154/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/curl
+ >=dev-libs/tinyxml-2.6.1[stl]
+ media-video/vdr"
+RDEPEND="${DEPEND}
+ || ( media-plugins/vdr-mplayer media-plugins/vdr-xineliboutput )"
+
+PATCHES=( "${FILESDIR}/${P}_unbundle-tinyxml2.diff"
+ "${FILESDIR}/${P}_gcc-4.7.patch" )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -e "s:ConfigDirectory():ConfigDirectory( \"vodcatcher\" ):" -i src/VodcatcherPlugin.cc
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/vodcatcher/
+ doins examples/vodcatchersources.conf
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ echo
+ elog "! IMPORTEND"
+ elog "In order to allow the MPlayer plug-in to play back the streams passed in by the"
+ elog "Vodcatcher, you must add the following entry to the mplayersources.conf file:"
+ echo
+ elog "/tmp;Vodcatcher;0"
+ echo
+}