summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-07-29 15:42:57 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-07-29 15:42:57 +0200
commit2a58353d033247fd01c00ebcd813a27109c3797c (patch)
tree0eec9ef1eb102344dbed0fb22a73a8a1b037c0db /media-radio
parentdev-libs/libzia: add 4.61 (diff)
downloadgentoo-2a58353d033247fd01c00ebcd813a27109c3797c.tar.gz
gentoo-2a58353d033247fd01c00ebcd813a27109c3797c.tar.bz2
gentoo-2a58353d033247fd01c00ebcd813a27109c3797c.zip
media-radio/tucnak: add 4.61
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak/Manifest1
-rw-r--r--media-radio/tucnak/metadata.xml1
-rw-r--r--media-radio/tucnak/tucnak-4.61.ebuild74
3 files changed, 76 insertions, 0 deletions
diff --git a/media-radio/tucnak/Manifest b/media-radio/tucnak/Manifest
index 820a08b43520..f8655dee32e7 100644
--- a/media-radio/tucnak/Manifest
+++ b/media-radio/tucnak/Manifest
@@ -1,2 +1,3 @@
DIST tucnak-4.59.tar.gz 6822110 BLAKE2B ba6a9912886c8ac5a0506c0170232f7f441e10d3bff2a45309cf4b03a67465165438c2955d080d7dd2616c0404594d7af370f5ada13337d91d46c07713ddf1a2 SHA512 a66ae8aba0bab19c1ac4a68889a9134eb24ba01e4ae444eac96c6f6829a09d307884ed4b448b606e2c9fea21d2fe33df68f5cd982177fc8d2c4b366ee090cfaa
DIST tucnak-4.60.tar.gz 6823505 BLAKE2B 4c0bea1a3f179f0ee8fe0b652f42148171c73b6b558f44c7ded86bc9964d08a13004c490fa4f9337ff92bf2c685b37682212171a0331cb47667a32019cc26ada SHA512 37f2820d451dae83ffdfe52e8a1a8a7195cb518a831b8e2d9553387c504a7407cf15a70d7744a2ed88585f12638c1ae3e62f47914b232e5b20f8b07d3c2fac8c
+DIST tucnak-4.61.tar.gz 6824381 BLAKE2B f995271f309d24725993bd243ade28744a81d5ab80f994dd3425336930bcd8212433f17d682575d3725243c0e1fc84510e9bd063a6b5372158d3a88558898e34 SHA512 67d17da2a321492c8c38f2207570631851122fe2615f7cc20716ad0906b0fc2422e414e0be91fdfad2474b08d20c4c05c0d2aec9ad2d1d6afc3450af0d9eeb62
diff --git a/media-radio/tucnak/metadata.xml b/media-radio/tucnak/metadata.xml
index d94c8d78c9bb..9421358483f1 100644
--- a/media-radio/tucnak/metadata.xml
+++ b/media-radio/tucnak/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="hamlib">Enables support by the Hamlib amateur radio
rig control library to get/set frequency and mode of the ham radio</flag>
+ <flag name="rtlsdr">Add support for rtlsdr hardware</flag>
</use>
</pkgmetadata>
diff --git a/media-radio/tucnak/tucnak-4.61.ebuild b/media-radio/tucnak/tucnak-4.61.ebuild
new file mode 100644
index 000000000000..e424442c7ed4
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.61.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib portaudio rtlsdr suid"
+
+RDEPEND="dev-libs/glib:2
+ ~dev-libs/libzia-4.61
+ media-libs/libsndfile
+ media-libs/libsdl2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0= )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib:= )
+ portaudio? ( media-libs/portaudio )
+ rtlsdr? ( net-wireless/rtl-sdr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) \
+ $(use_with hamlib) \
+ $(use_with fftw fftw3) \
+ $(use_with portaudio) \
+ $(use_with rtlsdr) \
+ --without-hidapi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}