summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/audacity/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/audacity/files')
-rw-r--r--media-sound/audacity/files/audacity-1.3.13-automagic.patch61
-rw-r--r--media-sound/audacity/files/audacity-1.3.13-ffmpeg.patch164
-rw-r--r--media-sound/audacity/files/audacity-1.3.14-typecast.patch15
3 files changed, 240 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-1.3.13-automagic.patch b/media-sound/audacity/files/audacity-1.3.13-automagic.patch
new file mode 100644
index 000000000000..4e7c2917e5db
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.13-automagic.patch
@@ -0,0 +1,61 @@
+--- audacity-src-1.3.13-beta.orig/configure.in
++++ audacity-src-1.3.13-beta/configure.in
+@@ -173,6 +173,9 @@
+ lib_preference=$withval,
+ lib_preference="system local")
+
++AC_ARG_WITH([alsa], AS_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++AC_ARG_WITH([jack], AS_HELP_STRING([--without-jack], [Build without jack library (default: test)]))
++
+ dnl AC_ARG_WITH(wx-version,
+ dnl [AS_HELP_STRING([--with-wx-version],
+ dnl [select wxWidgets version (if both installed) [2.8,]])],
+@@ -574,13 +577,21 @@
+ ;;
+ *)
+ dnl Unix
+- AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
+- if [[ $have_alsa = "yes" ]] ; then
+- LIBS="$LIBS -lasound"
+- fi
+- PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
+- if [[ $have_jack = "yes" ]] ; then
+- LIBS="$LIBS $JACK_LIBS"
++ if test "x$with_alsa" != "xno"; then
++ AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
++ if [[ $have_alsa = "yes" ]] ; then
++ LIBS="$LIBS -lasound"
++ else
++ AC_MSG_WARN([Support for alsa not available])
++ fi
++ fi
++ if test "x$with_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
++ if [[ $have_jack = "yes" ]] ; then
++ LIBS="$LIBS $JACK_LIBS"
++ else
++ AC_MSG_WARN([Support for jack not available])
++ fi
+ fi
+ AC_CHECK_LIB(hpi, HPI_SubSysCreate, have_asihpi=yes, have_asihpi=no, -lm)
+ if [[ $have_asihpi = "yes" ]] ; then
+--- audacity-src-1.3.13-beta.orig/lib-src/portmixer/configure.ac
++++ audacity-src-1.3.13-beta/lib-src/portmixer/configure.ac
+@@ -31,6 +31,8 @@
+ [AC_SUBST( cflags, ["$cflags -g"] ) AC_MSG_RESULT(yes)],
+ [AC_SUBST( cflags, ["$cflags -O2"] ) AC_MSG_RESULT(no)])
+
++AC_ARG_WITH([alsa], AC_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++
+ #
+ # Check for portaudio path
+ #
+@@ -133,7 +135,7 @@
+ have_support=yes
+ fi
+
+-if [[ $have_alsa = "yes" ]] ; then
++if [[ $have_alsa = "yes" -a "x$with_alsa" != "xno" ]] ; then
+ AC_MSG_NOTICE([Including support for ALSA])
+ AC_DEFINE(PX_USE_LINUX_ALSA)
+ objects="$objects px_linux_alsa.o"
diff --git a/media-sound/audacity/files/audacity-1.3.13-ffmpeg.patch b/media-sound/audacity/files/audacity-1.3.13-ffmpeg.patch
new file mode 100644
index 000000000000..675470913c8d
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.13-ffmpeg.patch
@@ -0,0 +1,164 @@
+--- audacity-src-1.3.13-beta.orig/src/export/ExportFFmpeg.cpp
++++ audacity-src-1.3.13-beta/src/export/ExportFFmpeg.cpp
+@@ -352,7 +352,7 @@
+ avcodec_get_context_defaults(mEncAudioCodecCtx);
+
+ mEncAudioCodecCtx->codec_id = ExportFFmpegOptions::fmts[mSubFormat].codecid;
+- mEncAudioCodecCtx->codec_type = CODEC_TYPE_AUDIO;
++ mEncAudioCodecCtx->codec_type = AVMEDIA_TYPE_AUDIO;
+ mEncAudioCodecCtx->codec_tag = av_codec_get_tag((const AVCodecTag **)mEncFormatCtx->oformat->codec_tag,mEncAudioCodecCtx->codec_id);
+ mSampleRate = (int)project->GetRate();
+ mEncAudioCodecCtx->global_quality = -99999; //quality mode is off by default;
+@@ -403,7 +403,6 @@
+ mEncAudioCodecCtx->flags2 = 0;
+ if (gPrefs->Read(wxT("/FileFormats/FFmpegBitReservoir"),true)) mEncAudioCodecCtx->flags2 |= CODEC_FLAG2_BIT_RESERVOIR;
+ if (gPrefs->Read(wxT("/FileFormats/FFmpegVariableBlockLen"),true)) mEncAudioCodecCtx->flags2 |= 0x0004; //WMA only?
+- mEncAudioCodecCtx->use_lpc = gPrefs->Read(wxT("/FileFormats/FFmpegUseLPC"),true);
+ mEncAudioCodecCtx->compression_level = gPrefs->Read(wxT("/FileFormats/FFmpegCompLevel"),-1);
+ mEncAudioCodecCtx->frame_size = gPrefs->Read(wxT("/FileFormats/FFmpegFrameSize"),(long)0);
+ mEncAudioCodecCtx->lpc_coeff_precision = gPrefs->Read(wxT("/FileFormats/FFmpegLPCCoefPrec"),(long)0);
+@@ -569,7 +569,7 @@
+ pkt.stream_index = mEncAudioStream->index;
+ pkt.data = mEncAudioEncodedBuf;
+ pkt.size = nEncodedBytes;
+- pkt.flags |= PKT_FLAG_KEY;
++ pkt.flags |= AV_PKT_FLAG_KEY;
+
+ // Set presentation time of frame (currently in the codec's timebase) in the stream timebase.
+ if(mEncAudioCodecCtx->coded_frame && mEncAudioCodecCtx->coded_frame->pts != int64_t(AV_NOPTS_VALUE))
+@@ -656,7 +656,7 @@
+
+ pkt.stream_index = mEncAudioStream->index;
+ pkt.data = mEncAudioEncodedBuf;
+- pkt.flags |= PKT_FLAG_KEY;
++ pkt.flags |= AV_PKT_FLAG_KEY;
+
+ // Write the encoded audio frame to the output file.
+ if ((ret = av_interleaved_write_frame(mEncFormatCtx, &pkt)) != 0)
+--- audacity-src-1.3.13-beta.orig/src/export/ExportFFmpegDialogs.cpp
++++ audacity-src-1.3.13-beta/src/export/ExportFFmpegDialogs.cpp
+@@ -1288,7 +1288,7 @@
+ while ((codec = av_codec_next(codec)))
+ {
+ // We're only interested in audio and only in encoders
+- if (codec->type == CODEC_TYPE_AUDIO && codec->encode)
++ if (codec->type == AVMEDIA_TYPE_AUDIO && codec->encode)
+ {
+ mCodecNames.Add(wxString::FromUTF8(codec->name));
+ mCodecLongNames.Add(wxString::Format(wxT("%s - %s"),mCodecNames.Last().c_str(),wxString::FromUTF8(codec->long_name).c_str()));
+@@ -1528,7 +1528,7 @@
+ // Find the codec, that is claimed to be compatible
+ AVCodec *codec = avcodec_find_encoder(CompatibilityList[i].codec);
+ // If it exists, is audio and has encoder
+- if (codec != NULL && (codec->type == CODEC_TYPE_AUDIO) && codec->encode)
++ if (codec != NULL && (codec->type == AVMEDIA_TYPE_AUDIO) && codec->encode)
+ {
+ // If it was selected - remember it's new index
+ if ((id >= 0) && codec->id == id) index = mShownCodecNames.GetCount();
+@@ -1543,7 +1543,7 @@
+ AVCodec *codec = NULL;
+ while ((codec = av_codec_next(codec)))
+ {
+- if (codec->type == CODEC_TYPE_AUDIO && codec->encode)
++ if (codec->type == AVMEDIA_TYPE_AUDIO && codec->encode)
+ {
+ if (mShownCodecNames.Index(wxString::FromUTF8(codec->name)) < 0)
+ {
+@@ -1563,7 +1563,7 @@
+ if (format != NULL)
+ {
+ AVCodec *codec = avcodec_find_encoder(format->audio_codec);
+- if (codec != NULL && (codec->type == CODEC_TYPE_AUDIO) && codec->encode)
++ if (codec != NULL && (codec->type == AVMEDIA_TYPE_AUDIO) && codec->encode)
+ {
+ if ((id >= 0) && codec->id == id) index = mShownCodecNames.GetCount();
+ mShownCodecNames.Add(wxString::FromUTF8(codec->name));
+--- audacity-src-1.3.13-beta.orig/src/FFmpeg.cpp
++++ audacity-src-1.3.13-beta/src/FFmpeg.cpp
+@@ -316,7 +316,7 @@
+ pd.buf_size = 0;
+ pd.buf = (unsigned char *) av_malloc(PROBE_BUF_MAX + AVPROBE_PADDING_SIZE);
+ if (pd.buf == NULL) {
+- err = AVERROR_NOMEM;
++ err = AVERROR(ENOMEM);
+ goto fail;
+ }
+
+@@ -381,7 +381,7 @@
+
+ // Didn't find a suitable format, so bail
+ if (!fmt) {
+- err = AVERROR_NOFMT;
++ err = AVERROR(EILSEQ);
+ goto fail;
+ }
+
+@@ -855,7 +855,6 @@
+ FFMPEG_INITDYN(codec, avcodec_find_decoder);
+ FFMPEG_INITDYN(codec, avcodec_get_context_defaults);
+ FFMPEG_INITDYN(codec, avcodec_open);
+- FFMPEG_INITDYN(codec, avcodec_decode_audio2);
+ FFMPEG_INITDYN(codec, avcodec_decode_audio3);
+ FFMPEG_INITDYN(codec, avcodec_encode_audio);
+ FFMPEG_INITDYN(codec, avcodec_close);
+--- audacity-src-1.3.13-beta.orig/src/FFmpeg.h
++++ audacity-src-1.3.13-beta/src/FFmpeg.h
+@@ -559,7 +559,11 @@
+ FFMPEG_FUNCTION_WITH_RETURN(
+ void*,
+ av_fast_realloc,
++#if LIBAVUTIL_VERSION_MAJOR < 51
+ (void *ptr, unsigned int *size, unsigned int min_size),
++#else
++ (void *ptr, unsigned int *size, size_t min_size),
++#endif
+ (ptr, size, min_size)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
+@@ -747,7 +751,11 @@
+ FFMPEG_FUNCTION_WITH_RETURN(
+ void*,
+ av_malloc,
++#if LIBAVUTIL_VERSION_MAJOR < 51
+ (unsigned int size),
++#else
++ (size_t size),
++#endif
+ (size)
+ );
+ FFMPEG_FUNCTION_NO_RETURN(
+--- audacity-src-1.3.13-beta.orig/src/import/ImportFFmpeg.cpp
++++ audacity-src-1.3.13-beta/src/import/ImportFFmpeg.cpp
+@@ -416,7 +416,7 @@
+ // Fill the stream contexts
+ for (unsigned int i = 0; i < mFormatContext->nb_streams; i++)
+ {
+- if (mFormatContext->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO)
++ if (mFormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ //Create a context
+ streamContext *sc = new streamContext;
+--- audacity-src-1.3.13-beta.orig/src/ondemand/ODDecodeFFmpegTask.cpp
++++ audacity-src-1.3.13-beta/src/ondemand/ODDecodeFFmpegTask.cpp
+@@ -156,7 +156,7 @@
+ //test the audio stream(s)
+ for (unsigned int i = 0; i < ic->nb_streams; i++)
+ {
+- if (ic->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO)
++ if (ic->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ audioStreamExists = true;
+ st = ic->streams[i];
+@@ -573,10 +573,10 @@
+ }
+ }
+
+- // avcodec_decode_audio2() expects the size of the output buffer as the 3rd parameter but
++ // avcodec_decode_audio3() expects the size of the output buffer as the 3rd parameter but
+ // also returns the number of bytes it decoded in the same parameter.
+ sc->m_decodedAudioSamplesValidSiz = sc->m_decodedAudioSamplesSiz;
+- nBytesDecoded = avcodec_decode_audio2(sc->m_codecCtx,
++ nBytesDecoded = avcodec_decode_audio3(sc->m_codecCtx,
+ sc->m_decodedAudioSamples, // out
+ &sc->m_decodedAudioSamplesValidSiz, // in/out
+ pDecode, nDecodeSiz); // in
diff --git a/media-sound/audacity/files/audacity-1.3.14-typecast.patch b/media-sound/audacity/files/audacity-1.3.14-typecast.patch
new file mode 100644
index 000000000000..c01046143b21
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.14-typecast.patch
@@ -0,0 +1,15 @@
+--- audacity-src-1.3.14-beta/src/TrackPanel.cpp.orig
++++ audacity-src-1.3.14-beta/src/TrackPanel.cpp
+@@ -2915,7 +2915,11 @@
+ {
+ // Make sure we always have the first linked track of a stereo track
+ if (!mouseTrack->GetLinked() && mTracks->GetLink(mouseTrack))
+- mouseTrack = mTracks->GetLink(mouseTrack);
++ mouseTrack =
++#ifndef USE_MIDI
++ (WaveTrack*)
++#endif
++ mTracks->GetLink(mouseTrack);
+
+ // Temporary apply the offset because we want to see if the
+ // track fits with the desired offset