summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-10-06 18:56:47 +0100
committerYixun Lan <dlan@gentoo.org>2023-10-17 05:23:48 +0000
commita19cfd05bb1bc1ed9ed84342a95bca123b347eb9 (patch)
tree38b17a5894055616d48b318ad9d04e94207afa7b /media-sound/clementine/files
parentgames-arcade/open-supaplex: drop 7.1.2 (diff)
downloadgentoo-a19cfd05bb1bc1ed9ed84342a95bca123b347eb9.tar.gz
gentoo-a19cfd05bb1bc1ed9ed84342a95bca123b347eb9.tar.bz2
gentoo-a19cfd05bb1bc1ed9ed84342a95bca123b347eb9.zip
media-sound/clementine: Fix build with new abseil and proto
Bug: https://bugs.gentoo.org/912853 Bug: https://bugs.gentoo.org/913738 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-sound/clementine/files')
-rw-r--r--media-sound/clementine/files/clementine-1.4.0_rc2-absl.patch15
-rw-r--r--media-sound/clementine/files/clementine-1.4.0_rc2-c17.patch67
2 files changed, 82 insertions, 0 deletions
diff --git a/media-sound/clementine/files/clementine-1.4.0_rc2-absl.patch b/media-sound/clementine/files/clementine-1.4.0_rc2-absl.patch
new file mode 100644
index 000000000000..48eb9dda4227
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.4.0_rc2-absl.patch
@@ -0,0 +1,15 @@
+Fix build
+
+https://bugs.gentoo.org/912853
+
+--- a/ext/libclementine-tagreader/CMakeLists.txt
++++ b/ext/libclementine-tagreader/CMakeLists.txt
+@@ -37,7 +37,7 @@ add_library(libclementine-tagreader STATIC
+ )
+
+ target_link_libraries(libclementine-tagreader
+- ${PROTOBUF_LIBRARY}
+ libclementine-common
++ ${PROTOBUF_LIBRARY} absl_log_internal_check_op absl_log_internal_message
+ )
+
diff --git a/media-sound/clementine/files/clementine-1.4.0_rc2-c17.patch b/media-sound/clementine/files/clementine-1.4.0_rc2-c17.patch
new file mode 100644
index 000000000000..3121b1e15bf0
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.4.0_rc2-c17.patch
@@ -0,0 +1,67 @@
+Fix build
+
+https://bugs.gentoo.org/912853
+
+--- a/3rdparty/libprojectm/CMakeLists.txt
++++ b/3rdparty/libprojectm/CMakeLists.txt
+@@ -24,7 +24,7 @@ set(BUILD_PROJECTM_STATIC ON)
+ set(DISABLE_NATIVE_PRESETS ON)
+ set(DISABLE_MILKDROP_PRESETS OFF)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17")
+
+ pkg_check_modules(GLEW glew)
+
+--- a/3rdparty/qtsingleapplication/CMakeLists.txt
++++ b/3rdparty/qtsingleapplication/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.0.0)
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++17")
+
+ set(SINGLEAPP-SOURCES
+ qtlocalpeer.cpp
+--- a/ext/libclementine-common/CMakeLists.txt
++++ b/ext/libclementine-common/CMakeLists.txt
+@@ -2,7 +2,7 @@ include_directories(${PROTOBUF_INCLUDE_DIRS})
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++17")
+
+ set(SOURCES
+ core/closure.cpp
+--- a/ext/libclementine-remote/CMakeLists.txt
++++ b/ext/libclementine-remote/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ include_directories(${PROTOBUF_INCLUDE_DIRS})
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++17")
+
+ set(MESSAGES
+ remotecontrolmessages.proto
+--- a/ext/libclementine-tagreader/CMakeLists.txt
++++ b/ext/libclementine-tagreader/CMakeLists.txt
+@@ -3,7 +3,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+ include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-common)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++17")
+
+ set(MESSAGES
+ tagreadermessages.proto
+--- a/gst/moodbar/CMakeLists.txt
++++ b/gst/moodbar/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 3.0.0)
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall --std=c++0x")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall --std=c++17")
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+