summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-23 05:57:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-23 05:57:08 +0200
commit52dccf86e53a748e226119f1e2ce7e39b2daecdd (patch)
treeb25899fcc456ce2cbd07ed2ec4556720bda9e633 /media-sound/whipper
parentdev-util/blueprint-compiler: Stabilize 0.12.0 amd64, #930463 (diff)
downloadgentoo-52dccf86e53a748e226119f1e2ce7e39b2daecdd.tar.gz
gentoo-52dccf86e53a748e226119f1e2ce7e39b2daecdd.tar.bz2
gentoo-52dccf86e53a748e226119f1e2ce7e39b2daecdd.zip
media-sound/whipper: Enable py3.12
Closes: https://bugs.gentoo.org/929672 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/whipper')
-rw-r--r--media-sound/whipper/whipper-0.10.0-r1.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/media-sound/whipper/whipper-0.10.0-r1.ebuild b/media-sound/whipper/whipper-0.10.0-r1.ebuild
index 451683de80dc..48549099d453 100644
--- a/media-sound/whipper/whipper-0.10.0-r1.ebuild
+++ b/media-sound/whipper/whipper-0.10.0-r1.ebuild
@@ -3,9 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
-
DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -17,7 +16,9 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-libs/libsndfile:="
+DEPEND="
+ media-libs/libsndfile:=
+"
# bug https://bugs.gentoo.org/923339
# upstream https://github.com/whipper-team/whipper/issues/605
# upstream https://github.com/whipper-team/whipper/issues/606
@@ -32,14 +33,20 @@ RDEPEND="
<dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
media-libs/mutagen[${PYTHON_USEDEP}]
- media-sound/sox[flac]"
+ media-sound/sox[flac]
+"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests unittest
-PATCHES=( "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch"
+)
python_prepare_all() {
# accurip test totally depends on network access