summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-12-15 16:38:13 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-15 16:38:13 +0100
commit1b42cd876d1f5119a68f5f9ab3f7b40a0b8e8616 (patch)
treee1ce75d9115db4f21afe81926f0d17883839e9d1 /media-sound
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-1b42cd876d1f5119a68f5f9ab3f7b40a0b8e8616.tar.gz
gentoo-1b42cd876d1f5119a68f5f9ab3f7b40a0b8e8616.tar.bz2
gentoo-1b42cd876d1f5119a68f5f9ab3f7b40a0b8e8616.zip
media-sound/scream: new ebuild
* Packaging https://github.com/duncanthrax/scream Closes: https://bugs.gentoo.org/718800 Closes: https://github.com/gentoo/gentoo/pull/15281 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/scream/Manifest1
-rw-r--r--media-sound/scream/metadata.xml15
-rw-r--r--media-sound/scream/scream-3.6.ebuild39
-rw-r--r--media-sound/scream/scream-9999.ebuild39
4 files changed, 94 insertions, 0 deletions
diff --git a/media-sound/scream/Manifest b/media-sound/scream/Manifest
new file mode 100644
index 000000000000..d7e02efe74da
--- /dev/null
+++ b/media-sound/scream/Manifest
@@ -0,0 +1 @@
+DIST scream-3.6.tar.gz 999237 BLAKE2B d199d9658958ac53d973c25421ee3a7f2c1ec9666c34596639942bcbfa5efb60e4aad033adc2fdbd810f676f412357283dc5fda6224752587498f7636ade1662 SHA512 4fd07a808d8f0ead3551061e96fe2f9b54ef6f34d1d615fb6454185fc6ffc67f71afb08a876550363cb3f8c15bbff461936808031e5aba5885626c92880e92ec
diff --git a/media-sound/scream/metadata.xml b/media-sound/scream/metadata.xml
new file mode 100644
index 000000000000..ed60e1c354ac
--- /dev/null
+++ b/media-sound/scream/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">duncanthrax/scream</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/scream/scream-3.6.ebuild b/media-sound/scream/scream-3.6.ebuild
new file mode 100644
index 000000000000..1c3ead36e4d3
--- /dev/null
+++ b/media-sound/scream/scream-3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+S="${WORKDIR}/${P}/Receivers/unix"
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+
+ cmake_src_configure
+}
diff --git a/media-sound/scream/scream-9999.ebuild b/media-sound/scream/scream-9999.ebuild
new file mode 100644
index 000000000000..1c3ead36e4d3
--- /dev/null
+++ b/media-sound/scream/scream-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+S="${WORKDIR}/${P}/Receivers/unix"
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+
+ cmake_src_configure
+}