summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-10-21 12:30:02 +0200
committerJohannes Huber <johu@gentoo.org>2018-10-21 12:32:10 +0200
commit2976cc265cc5bb3f9b44bbd7e3d4ea915052c2e7 (patch)
tree6b9f8e84beaf15dc291a4de15287cc6036ebcb80 /media-sound
parentdev-ruby/oauth2: fix install without git (diff)
downloadgentoo-2976cc265cc5bb3f9b44bbd7e3d4ea915052c2e7.tar.gz
gentoo-2976cc265cc5bb3f9b44bbd7e3d4ea915052c2e7.tar.bz2
gentoo-2976cc265cc5bb3f9b44bbd7e3d4ea915052c2e7.zip
media-sound/lollypop: Missing runtime dependencies
Reported-by: Garry Filakhtov <filakhtov@gmail.com> Closes: https://bugs.gentoo.org/669002 Closes: https://bugs.gentoo.org/669004 Signed-off-by: Johannes Huber <johu@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/lollypop-0.9.605-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/lollypop/lollypop-0.9.605-r1.ebuild b/media-sound/lollypop/lollypop-0.9.605-r1.ebuild
new file mode 100644
index 000000000000..16b08b545fe8
--- /dev/null
+++ b/media-sound/lollypop/lollypop-0.9.605-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="7e56defb7152c6cd7140e9ea98df4ce7"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+CDEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+DEPEND="${CDEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${CDEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}