summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-11-24 20:46:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-11-24 20:46:47 +0000
commitb52fc1b52bdf37dbb9a97af4c83737fd03f213d0 (patch)
tree9f14cd169e584e46fd6a0f42acb7daff62b12588 /media-tv
parentnet-print/hplip-plugin: Version bump to 3.19.11 (diff)
downloadgentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.tar.gz
gentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.tar.bz2
gentoo-b52fc1b52bdf37dbb9a97af4c83737fd03f213d0.zip
media-tv/dtv-scan-tables: Version bump to 0_p20190922
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/dtv-scan-tables/Manifest1
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild32
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild12
-rw-r--r--media-tv/dtv-scan-tables/files/Makefile.patch55
4 files changed, 35 insertions, 65 deletions
diff --git a/media-tv/dtv-scan-tables/Manifest b/media-tv/dtv-scan-tables/Manifest
index c7943ec318a8..f2344e5f8348 100644
--- a/media-tv/dtv-scan-tables/Manifest
+++ b/media-tv/dtv-scan-tables/Manifest
@@ -1 +1,2 @@
DIST dtv-scan-tables-2017-10-03-c1986d5148d8.tar.bz2 168709 BLAKE2B fb4a7ad5b6892a7e7eed1d57ebb49b1f4493076f6f744953d2d5c51c0e1cf7fdaf864ad050c578c2697f5b11d72c245b96ee369522cb58d38a1a2cef035099a7 SHA512 e2b0cf8f52b536be6a532b4a2896421a8150fdc19613e92c92d0c8275fcfd306cb091db32fa26f97bbec0a51ef4ba61b5f98e8c974280a3f6dd36b67a3bf4aad
+DIST dtv-scan-tables-2019-09-22-f07bde777d4d.tar.bz2 270211 BLAKE2B 76d5250a8eb7e9ce5c83eb9486ea1b398f3565ed027863057f143ae15c196fa01489f17fa71082ac878f49dac653da8967673872cb3e298f99cd59376c82ee39 SHA512 806fadcfc767d09dc9b474af089c2fa68ccafd91e110b74dc47f3a2ea90ebb74f80633831a20a51578fce3fbd4556a23c6bca9f7139be7c3de8eff79d2ee321c
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild
new file mode 100644
index 000000000000..73d9b36229da
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20190922.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="f07bde777d4d"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=media-tv/v4l-utils-1.4"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install install_v3
+ einstalldocs
+}
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
index 305e482a9150..73d9b36229da 100644
--- a/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
@@ -7,7 +7,7 @@ if [[ ${PV#9999} != ${PV} ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
else
- COMMIT="c1986d5148d8"
+ COMMIT="f07bde777d4d"
SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
S="${WORKDIR}/usr/share/dvb"
@@ -18,18 +18,10 @@ HOMEPAGE="https://linuxtv.org/"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-DEPEND=">=media-tv/v4l-utils-1.4"
+BDEPEND=">=media-tv/v4l-utils-1.4"
-PATCHES=( "${FILESDIR}"/Makefile.patch )
DOCS=( README )
-src_prepare() {
- default
-
- # Conversion failure!
- rm -v dvb-t/ke-Nairobi || die
-}
-
src_compile() {
emake dvbv3 dvbv5
}
diff --git a/media-tv/dtv-scan-tables/files/Makefile.patch b/media-tv/dtv-scan-tables/files/Makefile.patch
deleted file mode 100644
index 60c6cde17ef2..000000000000
--- a/media-tv/dtv-scan-tables/files/Makefile.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 17049393c60503d305787d06b7137227a99ed2af Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 13 Jul 2019 16:23:23 +0100
-Subject: [PATCH] Improve Makefile to avoid "Argument list too long" error
-
-I wouldn't expect a foreach loop to be prone to this issue but it's
-not the right way to write a Makefile anyway.
-
-Note that conversion failures are now fatal and the dvb-t/ke-Nairobi
-file is failing to convert at the moment.
-
-Signed-off-by: James Le Cuirot <chewi@gentoo.org>
----
- Makefile | 16 ++++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 901dc9d..7cdb5bc 100644
---- a/Makefile
-+++ b/Makefile
-@@ -17,6 +17,8 @@ DVBV3DIRS = atsc dvb-c dvb-s dvb-t
- DVBV5DIRS = $(DVBV3DIRS) isdb-t
-
- DVBV3CHANNELFILES = $(foreach dir,$(DVBV3DIRS),$(wildcard $(dir)/*))
-+DVBV3OUTPUTFILES = $(patsubst %,$(DVBV3OUTPUTDIR)/%,$(DVBV3CHANNELFILES))
-+DVBV5OUTPUTFILES = $(patsubst %,$(DVBV5OUTPUTDIR)/%,$(DVBV3CHANNELFILES))
-
- DVBFORMATCONVERT_CHANNEL_DVBV5 = -ICHANNEL -ODVBV5
- DVBFORMATCONVERT_CHANNEL_DVBV3 = -IDVBV5 -OCHANNEL
-@@ -42,14 +44,16 @@ ifeq ($(DVBV3DIR),)
- DVBV3DIR = dvbv3
- endif
-
--dvbv3:
-- @$(foreach var,$(DVBV3DIRS), $(MKDIR) $(DVBV3OUTPUTDIR)/$(var);)
-- @$(foreach var,$(DVBV3CHANNELFILES), $(DVBFORMATCONVERT) $(DVBFORMATCONVERT_CHANNEL_DVBV3) $(var) $(DVBV3OUTPUTDIR)/$(var);)
-+$(DVBV3OUTPUTFILES): $(DVBV3OUTPUTDIR)/%: %
-+ @$(MKDIR) "$(dir $@)"
-+ @$(DVBFORMATCONVERT) $(DVBFORMATCONVERT_CHANNEL_DVBV3) "$<" "$@"
-
-+$(DVBV5OUTPUTFILES): $(DVBV5OUTPUTDIR)/%: $(DVBV3OUTPUTDIR)/%
-+ @$(MKDIR) "$(dir $@)"
-+ @$(DVBFORMATCONVERT) $(DVBFORMATCONVERT_CHANNEL_DVBV5) "$<" "$@"
-
--dvbv5: $(DVBV3OUTPUTDIR)
-- @$(foreach var,$(DVBV3DIRS), $(MKDIR) $(DVBV5OUTPUTDIR)/$(var);)
-- @$(foreach var,$(DVBV3CHANNELFILES), $(DVBFORMATCONVERT) $(DVBFORMATCONVERT_CHANNEL_DVBV5) $(DVBV3OUTPUTDIR)/$(var) $(DVBV5OUTPUTDIR)/$(var);)
-+dvbv3: $(DVBV3OUTPUTFILES)
-+dvbv5: $(DVBV5OUTPUTFILES)
-
- install:
- @mkdir -p $(DATADIR)/$(DVBV5DIR)
---
-2.21.0
-