summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/luvcview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/luvcview')
-rw-r--r--media-video/luvcview/Manifest2
-rw-r--r--media-video/luvcview/luvcview-0.2.6.ebuild40
-rw-r--r--media-video/luvcview/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/media-video/luvcview/Manifest b/media-video/luvcview/Manifest
new file mode 100644
index 000000000000..901879f48008
--- /dev/null
+++ b/media-video/luvcview/Manifest
@@ -0,0 +1,2 @@
+DIST luvcview_0.2.6-4.diff.gz 8227 RMD160 8a27ecaa94de42fdee1c387659d56d7394860b33 SHA1 3a006a9b1685d18022f9731918366c194943ec78 SHA256 2e71076ef242751d7931d7ef3198d0e5688e29ab86be4f0125891dc972e46fb1
+DIST luvcview_0.2.6.orig.tar.gz 100318 RMD160 3257bbd92699dcb5ee94a6c8b9e38f1ecd508226 SHA1 1a3e54c0e365532261f727e27cb0179601b6980f SHA256 73c37160efaf62b896009d5686e7b21e37c1860a75e0454e8e5dbdded8a4e2d0
diff --git a/media-video/luvcview/luvcview-0.2.6.ebuild b/media-video/luvcview/luvcview-0.2.6.ebuild
new file mode 100644
index 000000000000..805bee013843
--- /dev/null
+++ b/media-video/luvcview/luvcview-0.2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+PATCH_LEVEL=4
+
+DESCRIPTION="USB Video Class grabber"
+HOMEPAGE="http://packages.qa.debian.org/l/luvcview.html"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/l/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/libv4l"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch debian/patches
+ sed -i -e 's:videodev.h:videodev2.h:' *.{c,h} || die
+ sed -i -e 's:-O2::' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin luvcview || die
+ doman debian/luvcview.1 || die
+ dodoc Changelog README ToDo || die
+}
diff --git a/media-video/luvcview/metadata.xml b/media-video/luvcview/metadata.xml
new file mode 100644
index 000000000000..92e4dbc04f50
--- /dev/null
+++ b/media-video/luvcview/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+</pkgmetadata>