summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild')
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
new file mode 100644
index 000000000000..67366efedb2f
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+SV="1.0.2-174"
+
+DESCRIPTION="Easily upload your wireshark captures to CloudShark"
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="http://appliance.cloudshark.org/downloads/${PN}-plugin-${SV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/${PN}-${SV}"
+
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, we fix that
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+ #causes errors, looks like it expects windows paths only
+ #echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
+ sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
+
+ #stuff to fix cloudshark_init.default to be more sane
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc CLOUDSHARK_README.txt
+}