summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 20:18:40 +0100
committerSam James <sam@gentoo.org>2021-04-03 20:52:56 +0100
commit0d89e74893170c7a6e9fc13f30d8754fef52246a (patch)
treed4300e0437a20600c3b878f79017fd3da36aefb9 /net-analyzer/ifstatus
parentnet-analyzer/arp-sk: eutils->epatch (diff)
downloadgentoo-0d89e74893170c7a6e9fc13f30d8754fef52246a.tar.gz
gentoo-0d89e74893170c7a6e9fc13f30d8754fef52246a.tar.bz2
gentoo-0d89e74893170c7a6e9fc13f30d8754fef52246a.zip
net-analyzer/ifstatus: eutils--, tidy up
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/ifstatus')
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild32
-rw-r--r--net-analyzer/ifstatus/ifstatus-2.0.0.ebuild28
2 files changed, 28 insertions, 32 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
index 10f512067d0b..986b1e4ad565 100644
--- a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils toolchain-funcs
+EAPI=7
-KEYWORDS="amd64 arm ~ppc x86"
+inherit toolchain-funcs
DESCRIPTION="A simple CLI program for displaying network statistics in real time"
HOMEPAGE="http://ifstatus.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="amd64 arm ~ppc x86"
RDEPEND=">=sys-libs/ncurses-4.2:0="
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/${PN}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-gcc43.patch"
- "${FILESDIR}/${P}-tinfo.patch"
- "${FILESDIR}/${P}-gcc6.patch"
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_prepare() {
@@ -37,8 +35,8 @@ src_install() {
}
pkg_postinst() {
- elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
- elog "before running ifstatus. For example, you may add"
- elog "Interfaces = eth0 there. Read the README file for"
- elog "more information."
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
}
diff --git a/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
index c954845ed7db..3aea08cd6d90 100644
--- a/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
+++ b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
@@ -2,31 +2,29 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
-KEYWORDS="amd64 arm ~ppc x86"
+inherit toolchain-funcs
DESCRIPTION="A simple CLI program for displaying network statistics in real time"
HOMEPAGE="http://ifstatus.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="amd64 arm ~ppc x86"
+
+RDEPEND=">=sys-libs/ncurses-4.2:0="
+DEPEND="${RDEPEND}"
+BDEPEND+"virtual/pkgconfig"
-RDEPEND="
- >=sys-libs/ncurses-4.2:0=
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
PATCHES=(
"${FILESDIR}"/${PN}-2.0.0-tinfo.patch
)
-S="${WORKDIR}/${PN}-v${PV}"
src_compile() {
tc-export CXX PKG_CONFIG
- emake GCC=$(tc-getCXX) ${PN}
+ emake GCC="$(tc-getCXX)" ${PN}
}
src_install() {
@@ -35,8 +33,8 @@ src_install() {
}
pkg_postinst() {
- elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
- elog "before running ifstatus. For example, you may add"
- elog "Interfaces = eth0 there. Read the README file for"
- elog "more information."
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
}