summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-05-25 09:25:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-05-25 09:25:38 -0400
commit05cc9dc260cd9098de4bd2d940f3b6bf27541e10 (patch)
tree06c12df2bc1c603b6e5e3e459eae32eebc8ed848 /net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild
parentapp-arch/pdlzip: Bump to 1.7 (diff)
downloadgentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.tar.gz
gentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.tar.bz2
gentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.zip
net-analyzer/nagios-check_rbl: new revision for perl-5.24 compatibility.
The tarball for this package was shipped with a copy of inc/version.pm that was causing problems with perl-5.24. Since v1.3.7 was added to the tree, upstream has moved SRC_URI to github, and re-released v1.3.7 with modified source code. The new tarball does not exhibit the version.pm problem. To fix the issue, this revision uses the new tarball, but renames it to include the -r1 suffix so that users don't see checksum failures. We are also removing inc/version.pm in src_prepare(). Comments have been added to the ebuild so that we can check for an upstream fix at a later time. The new revision also uses EAPI=6. Gentoo-Bug: 583966 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild')
-rw-r--r--net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..c75db07605cb
--- /dev/null
+++ b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Needed for perl_rm_files in src_prepare() only.
+inherit perl-functions
+
+DESCRIPTION="Monitor whether or not a host is blacklisted"
+HOMEPAGE="https://github.com/matteocorti/check_rbl"
+
+MY_P="${P/nagios-/}"
+
+# We rename the tarball here because the upstream source changed without
+# a new release. That change happens to fix bug #583966, so we do want
+# the newer tarball. But I think, without the rename, that user might
+# have gotten a checksum failure.
+SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${MY_P}.tar.gz
+ -> ${MY_P}-r1.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa"
+IUSE=""
+
+# The package's INSTALL/Makefile.PL files specify its dependencies.
+#
+# * Data::Validate::Domain (dev-perl/Data-Validate-Domain)
+# * Data::Validate::IP (dev-perl/Data-Validate-IP)
+# * IO::Select (dev-lang/perl)
+# * Monitoring::Plugin (dev-perl/Monitoring-Plugin)
+# * Monitoring::Plugin::Getopt (dev-perl/Monitoring-Plugin)
+# * Monitoring::Plugin::Threshold (dev-perl/Monitoring-Plugin)
+# * Net::DNS (dev-perl/Net-DNS)
+# * Readonly (dev-perl/Readonly)
+#
+RDEPEND="dev-lang/perl
+ dev-perl/Data-Validate-Domain
+ dev-perl/Data-Validate-IP
+ dev-perl/Monitoring-Plugin
+ dev-perl/Net-DNS
+ dev-perl/Readonly"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # The copy of version.pm that upstream ships causes problems and
+ # isn't necessary. They probably shouldn't be shipping it at all.
+ # See bug #583966 for more information. You should check on
+ # https://github.com/matteocorti/check_rbl/issues/6 every once
+ # in a while to see if this can be removed.
+ perl_rm_files inc/version.pm
+}
+
+src_configure() {
+ perl Makefile.PL INSTALLDIRS=vendor || die
+}
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+
+ # It's simplest to move this file after it's been installed.
+ dodir "${nagiosplugindir}"
+ mv "${D}"/usr/bin/check_rbl "${D}"/"${nagiosplugindir}" || die
+}